Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Automation Rule is Not Updating

We had recently gone through an upgrade from JIRA Service Desk 4.05 to JIRA Service Management 4.20.  

 

After upgrading, I was attempting to update existing automation rules.  Basically the automation rule is to add our support team members as participants when a ticket is created.  

I updated the automation to remove our support team members as participants.  However, I am still noticing the automation rule is still persisting.  Meaning, the support team members are still being added as participants.  

Has anyone noticed this issue when going through an upgrade?  I am using JIRA Service Management and help support it for my team and do not have full administration rights.  So, I am unable to trace where the rule is coming from or why it's not updating.  

I even attempted to create a brand new automation rule or turned off the old rule.  However, I am noticing it's still persisting.  

Does anyone know why this would happen or where I can troubleshoot this issue?

 

1 answer

0 votes
John Funk Community Leader Dec 29, 2021

Hi James,

I have not seen that. Are you on Server? Data Center? Cloud? 

Are you sure you published the Rule? When you go back into the Rule after a refresh, are your changes there?

Are you sure there is not another rule being fired at the same time?

As I understand it, there seems to be a new custom field that was introduced. 

We have automation rules that adds Agents/Customers to the ticket notifying when a new ticket is created.  

1) The automation rule will alert the appropriate agent(s) using the Alerts

2) The automation rule also edits the request ticket to add agent(s) in the Participants field.

 

We are noticing if you create a ticket through the customer portal and have an automation rule that alerts a user.  The same user is automatically added to a the Request Participants field. This seems to be a bug and was highlighted by another user.  We didn't see this in version 4.05.   

https://jira.atlassian.com/browse/JSDSERVER-10909?src=confmacro

 

I was also confused that our project now has a participants field and a request participants field. 

My automation rule adds users to the participants field not request participants. I am only able to see the Request Participants under my agent view.  I had to add the participants field under the view to see the users add on the alert.  

Like John Funk likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Software

👋 Looking for 15-20 volunteers to test Atlassian training content

Hi everyone! Are you interested in beta testing Atlassian University’s newest (unreleased!) training course? We’re looking for 15-20 volunteers to test our newest training course, Basic reporting...

529 views 19 25
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you