Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,369,757
Community Members
 
Community Events
168
Community Groups

Add customer on Jira ServiceDesk doesn't allow email-adress

When attempting to add a Customer to Jira ServiceDesk, the following message is shown:

"Successfully added 0 customers. The following customers could not be added:
[place of mail-address]
Please check the email addressess and try again."

When I click on the crossmark-symbol next to the mailaddress above, it says "[place of mail-address] is not a valid email address"

After double- and triple-checking the spelling and testing the customer's e-mail (it has been in use for over ten years), the same message is given. Other customers from the same domain can be added.

How can this be resolved?

3 answers

2 accepted

0 votes
Answer accepted

Hi, we had the same error. In our case the user already had a standard license on atlassian but the account was disabled. Check if you are in the same situation too: user already present but with 'site access' permission revoked.

ps. we are using dots inside emails without problems.

Regards, Tomas

Thanks Tomas,

We found a solution by adding the user from the  User Management section, deleting it, then attempting again from the ordinary Add Customer section.

Like # people like this
0 votes
Answer accepted
John Funk Community Leader Apr 12, 2021

Hi Oscar - Welcome to the Atlassian Community!

Are there any special characters in the email address? Or double periods or things of that nature? 

Have you tried to add the user under the User Management section? 

Thanks John,

There are no special characters in the email address.

It worked after (1) adding the user from User Management section, as recommended, then (2) removing the user, and (3) adding the user again from Add Customer section - since ordinary Customer access was desired. 

Like John Funk likes this

I have same issue sometime - but found that the email address already existed as a customer in that Portal. In the pop-up box, where you pasted or types the new email address, it will list the full name of the customer, if it already exists.  If you select that name, the error clears and you can now SAVE.

If you don't get a name results in that box, then I am sorry I have not encountered that.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events