Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Add customer on Jira ServiceDesk doesn't allow email-adress

When attempting to add a Customer to Jira ServiceDesk, the following message is shown:

"Successfully added 0 customers. The following customers could not be added:
[place of mail-address]
Please check the email addressess and try again."

When I click on the crossmark-symbol next to the mailaddress above, it says "[place of mail-address] is not a valid email address"

After double- and triple-checking the spelling and testing the customer's e-mail (it has been in use for over ten years), the same message is given. Other customers from the same domain can be added.

How can this be resolved?

2 answers

2 accepted

0 votes
Answer accepted
John Funk Community Leader Apr 12, 2021

Hi Oscar - Welcome to the Atlassian Community!

Are there any special characters in the email address? Or double periods or things of that nature? 

Have you tried to add the user under the User Management section? 

Thanks John,

There are no special characters in the email address.

It worked after (1) adding the user from User Management section, as recommended, then (2) removing the user, and (3) adding the user again from Add Customer section - since ordinary Customer access was desired. 

Like John Funk likes this
0 votes
Answer accepted

Hi, we had the same error. In our case the user already had a standard license on atlassian but the account was disabled. Check if you are in the same situation too: user already present but with 'site access' permission revoked.

ps. we are using dots inside emails without problems.

Regards, Tomas

Thanks Tomas,

We found a solution by adding the user from the  User Management section, deleting it, then attempting again from the ordinary Add Customer section.

Like John Funk likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket Pipelines

Bitbucket Pipelines Runners is now in open beta

We are excited to announce the open beta program for self-hosted runners. Bitbucket Pipelines Runners is available to everyone. Please try it and let us know your feedback. If you have any issue...

260 views 5 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you