Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

Recognition

  • Give kudos
  • My kudos

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage
Highlighted

Microsoft Flow to Jira Integration - Connection Fine But No Data

I have a use case whereby I need to create a Jira Epic within a specific project off the back of a response to a Microsoft Form. I am doing this within my own environments first before applying to a wider client use case which is based on the same integration.

I am using Jira Cloud and Microsoft Flow. I have provided the correct connection string and set up the API Token. The flow executes and when I check the Jira API token it also suggests connection has worked.

The issue I am having is there is no data being pulled into Flow from my JIRA instance so I cannot see any projects or subsequent details.

Is there anything I am missing on either the JIRA side or the Flow side of things? I'm not getting any error messages at all which is not helpful as no matter what I try I cannot resolve the issue to pull data through correctly.

It is probably something simple but the lack of any errors is not helping.

 

3 comments

What message do you get when you post the message you think Flow is sending to Jira by hand (with a curl or wget)?

So this may just be me but I thought (probably naively) building of the flow (in Microsoft Flow) would be dynamic.

In my head the logical steps for creating an Issue within a project would be to provide:-

  1. The Project itself
  2. The Issue Type to create
  3. Issue Title / Description

Based on the above I have tried to replicate getting the Projects List through using what I think Flow will send and I get a 404 error. I did however notice the getProjects api endpoint has been deprecated.

In case that was the problem I sent the command to get a particular project using the getProject api endpoint specifying the project key in the command and got the same error. 

I can see the API token I have created is being used but am at a loss to understand why I'm not getting a response.

Microsoft Flow does not help either as it provides minimal detail. 

Any other pointers you can provide for me to resolve this would be appreciated as if I can't solve basic connectivity issues there is not much hope for the wider enterprise use case I am hoping to implement.

Thanks.

Having dome some further investigation this looks like it is an issue with how Microsoft Flow is making the API calls.

I've set up a similar model using AWS and a Splunk app and it is able to create tickets and comments using the API token I've given the Splunk app.

I'll reach out to the Microsoft Forums to see if they can provide any additional insights as it all seems a bit strange.

Please ignore this. Microsoft Flow has now started behaving as I expected too. It's all been very strange.

Comment

Log in or Sign up to comment
TAGS
Community showcase
Published in Jira Software

How to create Jira issus from Excel file?

When to use CSV importer When managing your processes in Jira, there are many occasions where you need to create a lot of tasks. Creating them one by one will cost you a lot of time and effort and i...

4,583 views 22 33
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you