Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,296,045
Community Members
 
Community Events
165
Community Groups

i cannot respond to customers after upgrade

So today I updated Jira and all applications to the newest Version. So i updated from version 8.20.2 to verison 8.22.3 and after update of jira software i updated jira service Management as well. Before the update i checked the plugins and updated them as well, so that they are compatible, as described in the kb article before upgrading. 

After i updated everyhting and checked if everything is working i got 2 Problems now. When i open a Ticket that was made by a customer and click on "assign to me" the page gets faded and nothing happens. I can then reload the page and the ticket is assigned to me. After that, i want to add a comment or answer the customer. But when i click the button "respond to customer" the page again just fades out and shows the loading screen. I cannot answer my customer and i also cannot answer via the "comments" section below the issue that was oppened by the customer. What have i done wrong or where can i start to see what causes the problem?

Please find attached 2 screenshots to see my problem. 

jrATNYyKGA.jpgaMWJe1QdEx.jpg

 

4 answers

3 accepted

3 votes
Answer accepted

Ok @Rilwan Ahmed @Joseph Chung Yin 

it seems that Service Management 5 is not working with jira 8.22.3. So i updated again today with the service management package for linux and updated jira core to version 9. After that i updated jira software to version 9 in the applications and reindexed everything. Now it works again. Thanks for all your help. 

 

Greetings Thomas

0 votes
Answer accepted

Hi @v_tm ,

  1. Are you facing the issue in different browsers and in incognito mode as well ?
  2. disable only the upgraded plugins and check issue exists. If yes, enable safe mode and check if issue still exists. 
  3. Restart jira once again after deleting the cache. i.e.
    • Shut down JIRA
    • Delete the following hidden plugin cache directories:
      JIRA_HOME/plugins/.bundled-plugins
      JIRA_HOME/plugins/.osgi-plugins
    • Restart JIRA (These directories will be recreated on JIRA reboot with new plugin cache)
  4. Did you run the full re-index after the upgrade ?

Hi @Rilwan Ahmed ,

thanks for your answer. Let me answer your questions:

1. Yes the issue is in different browsers and incognito mode as well

2. when i try to activate "safe mode" it says that an unexpected error occured. Further information are in the logs

3. I did exakt what you wrote. Still no reponds from my customer or the ability to answer the tickets

4. Yes i reindexed now 10 times or more. Did not help either.

 

Do you have any other suggestions?

 

Thanks.

Hello @Rilwan Ahmed ,

so it seems that jira could disable all plugins except one called: Advanced Roadmaps fpr Jira. So i disabled it manually. After disabling all plugins i reindexed again but that did not help either. So i think it is not a problem of a plugin. I only have a few plugins installed. 

Greetings

Thomas

I also suggest to open a ticket with Atlassian Support as informed by @Joseph Chung Yin 

Open https://support.atlassian.com/contact/#/

  1. Select What can we help you with? =  Technical issues and bugs
  2. Which product is this for? = Jira Service management from the right column

    image.png

  3. Enter your SEN number
    https://<BaseURL>plugins/servlet/applications/versions-licenses
  4. Reproduce the issue and attach the support zip

Hello Rilwan,

i cannot open a ticket because i have only a starter license. It says, i can open a question in the community spaces...

@v_tm 
Page loading Issue is only with you or for other users as well ? 
If its only for you, restart your PC/Laptop and check again. 

Also when you reproduce the issue, check the browser developer tools --> Network tab and Console. See if any errors. 

0 votes
Answer accepted

@v_tm -

I think the best way on troubleshooting this issue is formally submit a support request to Atlassian Support (https://support.atlassian.com) with your support zip as an attachment.  They will be able to evaluate the logs for you.

When generating the log files for the support zip, you should try to reproduce your issues, and then generate the support zips.  If you want to access the log files on your end without Atlassian's support, you should look into the atlassian-jira.log for possible errors message.

Lastly, have you try to bounce the system to see if the restart will resolve your issue?

Hope this helps.

Best, Joseph Chung Yin

Jira/JSM Functional Lead, Global Infrastructure Applications Team

Viasat Inc.

Hello @Joseph Chung Yin ,

when i click your link and choose my licenseces i only can start a conversation in the atlassian community. I cannot open a ticket there. Where do i have to click to raise a ticket?

s7gZE0Ktmv.jpg

Thanks and Greetings

0 votes

@v_tm -

Great that your issue is resolved.  Please click on "Accept Answer" on Rilwan and my answer when you have a chance.

Best, Joseph

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
8.22.3
TAGS
Community showcase
Posted in Jira Service Management

Jira Service Management Documentation Opportunities

Hello everyone, Hope everyone is safe! A few months ago we posted an article sharing all the new articles and documentation that we, the AMER Jira Service Management team created. As mentioned ...

310 views 0 9
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you