Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Why can't I create knowledge base link between JSM and Confluence

Edited

I'm a site admin of our Jira/JSM/Confluence and I have administrative permissions for a JSM project and confluence space. I try to link the confluence space as a knowledge base to my JSM project, but the linking fails (HTTP 403). The only error message I can see is "We couldn't link the space 'XYZ'\n refresh the page and try again"

The global permissions of Confluence are set to allow JSM user to use confluence and view user profile

Is there something I'm missing here? I have tried to Google the issue and to see instruction articles but without success...

Edit:

Also I'm unable to create a Confluence space from JSM side, but from Confluence I have no issues. When I try to create a space from JSM project settings, I get follwing error:

JSM-Confluence.PNG

However, Confluence is not down or my permissions (as a site admin with full privileges) shouldn't be the issue.

1 answer

@Jussi Sarén I would recommend going through the step-by-step guide thoroughly, each section has some very useful tips and tricks and things to look out for, such as making sure the permissions/configuration items are all set correctly.

Hopefully this helps!

Thanks @Callum Carlile _Automation Consultants_ for the link. I have carafully read the instructions but I wasn't able to solve the issue. For me, as a software engineer, it looks like issue is caused by a permission problem, but all the permission mentioned here are met but still I'm unable to link the Confluence space with my JSM project. I also checked that I'm having a "company-managed" project so the linked article should apply on this case.

@Jussi Sarén Under the 'User Groups' tab in the global permissions, are you definitely within one of the groups which has the Create Space permission?

If you are, and you have correctly followed the steps within the linked documentation without any luck, then I might suggest raising a support ticket with Atlassian as it could be a bug or other technical issue

@Callum Carlile _Automation Consultants_  yes. I belong into administrators group which has both, create space and personal space permissions. I have also created spaces directly in Confluence lately so that shouldn't be the issue. Maybe I'm going to raise a support request. 

We got this issue solved with Atlassian support. There was a permission issue. My JSM project's permission set didn't grant "Service Project Agent" permission to our "Administrators" group and that was the issue. The need of this permission (even if it's now obvious) wasn't mentioned in the step-by-step guide and therefore I wasn't able to self-diagnose this by myself. However I requested Atlassian to update the instuctions so that the demand of  the permission would be mentioned.

@Jussi Sarén I'm glad you've got it all sorted! :)

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

Next level incident management in Jira Service Management

Hello Atlassian Community! We’re thrilled to announce some exciting changes to incident management in Jira Service Management Cloud, in order to give your teams extra muscle during incidents, and ...

1,608 views 20 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you