Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Tickets not visible on the Jira Service desk Interface

Hello,

We just updated from Jira service desk 3.16 to 4.13. Also we upgraded mysql from 5.6 to 8.0 ( mysql 8.0 is compatible with jira service desk 4.13). The MySQL Upgrade was successfull. The issue is that when connecting the Jira to the database i can't find the tickets on the jira service desk interface. i have tried to do a Re-indexing on the System page of Jira interface but i have the error "Désolé, nous avons eu des problèmes technique pendant votre dernière opération". I have gone through all the necessary steps of jira migration ( including moving modified files from the jira service desk 3.16). 

Note that the installation of Jira service desk 4.13 and upgrade to MySQL 8.0 is done on the same server. (the original installation of jira service desk 3.16 and mysql 5.6 are on another server)

What can the issue be? Can you please help to resolve this issue?

If you need any additional information i am at your disposal. 

 

Best regards,

Bruno.

4 answers

Hi @Bruno Casimir could you provide us with a log files? You can find them in {jira_home}/log/atlassian-jira.log (https://confluence.atlassian.com/adminjiraserver/important-directories-and-files-938847744.html)

Dirk Ronsmans Community Leader Oct 27, 2020

@Bruno Casimir ,

Can you check the application-jira.log ? The GC log isn't one that we can find much in :)

Hi @Bruno Casimir as you mentioned bellow, your log file is not up to date. It is not possible. Are you checking correct environment? Can you describe your server instance? You mentioned that you are using separate servers for old and new Jira? Are you checking NEW Jira server?

Hello, yes i am checking on the right server. other logs are updated, but not the atlassian-jira.log. Can you provide me an email address so as i send you all the logs? i cannot upload the logs on the comments.

Hello,

Sorry, the was another atlassian-jira.log. i have found the right one. is there a way to give you the full log file. the full log is too big to paste in the comments.

@Bruno Casimir just try to share it and post the link here. Or you can try to check it on your own. And maybe during reindex process (as @Dirk Ronsmans suggested) you will see some errors.

I d'ont understand the the log language : here is a part of the log when i try to do a re indexing :

Caused by: com.google.template.soy.data.SoyDataException: Attempted to coerce undefined value into a string.
at com.google.template.soy.data.restricted.UndefinedData.toString(UndefinedData.java:48) [?:?]
at com.google.template.soy.sharedpasses.render.EvalVisitor.visitPlusOpNode(EvalVisitor.java:454) [?:?]
at com.google.template.soy.sharedpasses.render.EvalVisitor.visitPlusOpNode(EvalVisitor.java:87) [?:?]
at com.google.template.soy.exprtree.AbstractReturningExprNodeVisitor.visit(AbstractReturningExprNodeVisitor.java:103) [?:?]
at com.google.template.soy.sharedpasses.render.EvalVisitor.visitPlusOpNode(EvalVisitor.java:447) [?:?]
at com.google.template.soy.sharedpasses.render.EvalVisitor.visitPlusOpNode(EvalVisitor.java:87) [?:?]
at com.google.template.soy.exprtree.AbstractReturningExprNodeVisitor.visit(AbstractReturningExprNodeVisitor.java:103) [?:?]
at com.google.template.soy.sharedpasses.render.EvalVisitor.visitPlusOpNode(EvalVisitor.java:447) [?:?]
at com.google.template.soy.sharedpasses.render.EvalVisitor.visitPlusOpNode(EvalVisitor.java:87) [?:?]
at com.google.template.soy.exprtree.AbstractReturningExprNodeVisitor.visit(AbstractReturningExprNodeVisitor.java:103) [?:?]
at com.google.template.soy.sharedpasses.render.EvalVisitor.visitExprRootNode(EvalVisitor.java:148) [?:?]
at com.google.template.soy.sharedpasses.render.EvalVisitor.visitExprRootNode(EvalVisitor.java:87) [?:?]
at com.google.template.soy.exprtree.AbstractReturningExprNodeVisitor.visit(AbstractReturningExprNodeVisitor.java:81) [?:?]
at com.google.template.soy.exprtree.AbstractReturningExprNodeVisitor.visit(AbstractReturningExprNodeVisitor.java:73) [?:?]
at com.google.template.soy.basetree.AbstractReturningNodeVisitor.exec(AbstractReturningNodeVisitor.java:43) [?:?]
at com.google.template.soy.sharedpasses.render.RenderVisitor.eval(RenderVisitor.java:739) [?:?]
... 336 more
, referer=http://localhost:8080/secure/admin/IndexAdmin.jspa, servletErrorMessage=}
2020-10-27 10:27:06,116+0100 plugin-transaction-0 INFO [c.a.jira.plugin.PluginTransactionListener] [plugin-transaction] numberStartEvents:537, numberEndEvents:537, numberSendEvents:271, numberEventsInTransactions:11200, numberOfPluginEnableEvents:269

Ok, so try to share the whole log file via some file share service.

Dirk Ronsmans Community Leader Oct 27, 2020

Looks like a plugin issue..

I'd still advice you to start with safe mode and go from there.

Could you also maybe list what plugins you have installed?

As shown above, i have not installed any plug in or apps. On the ancient Jira service desk version there we sone language pack installed by default and that's all.

Can you access the log file from here?

https://gofile.io/d/vtfjGi

@Bruno Casimir I was checking it, the errors are weird, but it is quite similar to https://community.atlassian.com/t5/Jira-Core-questions/cannot-re-index-after-Jira-Core-upgrade-from-7-13-to-8-5/qaq-p/1425023, can you really try to "disable plug-ins" when starting Jira or check that no JavaScript is set in announcment banner?

Hello,

Yes i have disabled plug ins at start( there was no plugins installed). Announcement banner is not configured on the ancient Jira version. 

I have tried installing our current version of jira service desk 3.16 with MySQL 5.7 on the new server (from scratch with a newly downloaded setup) and in works fine.

With the Jira service desk 4.12 and above( which are compatible with mysql 8.0) there seem to be an issue even before i import the modified and configured files from the 3.16 Jira service desk installation. The configuration of Jira 4.12 is not as fluid as the 3.16 on the browser. For example to configure the database with the 3.16 i get it directly on he browser whereas with the 4.12 the page does not load and I must go through the config.bat file.

I think the question is what is different between installing jira service desk 3.16 with Mysql 5.7 and installing jira 4.12/4.13 with mysql 8.0.**?

Is it possible to have a direct call with someone with in the Jira support team? Or can we have an exchange by mail? Is the Atlassian community the only support i can get or there is another way to get a more detailed troubleshoot with a Jira expert?

 

Thank you in advance.

The subject is becoming a bit urgent.

Best regards,

Dirk Ronsmans Community Leader Oct 28, 2020

@Bruno Casimir

Absolutely.

If you have a valid maintenance contract you can go to https://support.atlassian.com  and log a ticket with Atlassian directly

You just need your SEN and they can help you troubleshoot further.

What we do is just by experience and best effort.

Hello guys, 

The issue was the version of browser i was using. Jira service desk 4.12 and above does not work on IE11 and ancient versions of firefox. Whereas for Jira service desk 3.16 it works.

With the latest version of portable firefox it works fine.

Thank you and sorry to take your time for this issue which seems simple now.

Thank you again.

Best regards,

Bruno.

hi @Bruno Casimir , ok, thank you for the information. Sh*t happens from time to time :D but it's great it's working for you now :).

I suggest you to try to resolve the errors in your log file...maybe with Atlassian support.

0 votes

Hi @Bruno Casimir

Seems like your re-index is failing?

Have you tried building an index from scratch? (stop instance, remove index files, restart)

JIRA does not directly use the DB to show the issues but indeed the lucene index. If that fails/does not exist no issues will be shown.

Can you share the log that is occuring when your indexing fails?

My guess is that this will be related to some plugin/app

Edit: a quick troubleshoot could be to set the instance on Safe mode and see if the index works then. If yes, you can see which app is causing an issue by enableing one by one.

Hello Dirk,

Yes the re indexing fails. I do not find any log generated while the indexing failed. Yes i have tried to remove all the index files and restart jira but same issue. 

The errors i posted above tells helps? There are other logs but can't find errors in it.

Can you give me the steps to troubleshoot if this is an app/plugin issue? To be noted that there is no internet access on the server on which jira is installed.

Best regards,

Dirk Ronsmans Community Leader Oct 27, 2020

When you start a re-index, could you check the application-jira.log and maybe post what is going on there?

Even if it's not an error it could give us a clue.

 

with regards to troubleshooting apps. if you go to "manage apps" you should see a link at the bottom "enter safe mode".

image.png

This will disable the apps and you can try and re-index then. If it works then one of your apps is causing the issue and you can re-enable them one by one to see which one.

Also did you verify your apps are still compatible with the version of JIRA you're currently running?

The Atlassian-jira.log is not updated when i try a re indexing. one interesting thing i found these lines below in the log. May be this is the issue, i can see the atlassian-jira.og is not updated since the installation done on 23/10/2020 :

2020-10-23 03:44:22,904+0200 JIRA-Bootstrap INFO [c.a.j.config.database.DatabaseConfigHandler] Database password decryption not performed.
2020-10-23 03:44:23,309+0200 JIRA-Bootstrap ERROR [c.a.jira.health.HealthChecks] The jira.home directory is locked
2020-10-23 03:44:23,309+0200 JIRA-Bootstrap ERROR [c.a.jira.health.HealthChecks] The jira.home directory C:\Program Files\Atlassian\Application Data\Jira is locked by another running instance of JIRA. Your jira.home directory can only be used by one running JIRA instance.
Review our documentation for more information on setting your JIRA home.
2020-10-23 03:44:23,614+0200 JIRA-Bootstrap INFO [c.a.jira.startup.JiraStartupLogger] Running Jira startup checks.
2020-10-23 03:44:23,615+0200 JIRA-Bootstrap FATAL [c.a.jira.startup.JiraStartupLogger] Startup check failed. Jira will be locked.
2020-10-23 03:44:23,822+0200 JIRA-Bootstrap INFO [c.a.jira.startup.LauncherContextListener] Startup is complete. Jira is ready to serve.

The browser version i was using was not compatible with the version of jira service desk i installed.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

Why upgrade to Jira Service Management Premium?

We often have questions from folks using Jira Service Management about the benefits to using Premium. Check out this video to learn how you can unlock even more value in our Premium plan.  &nb...

235 views 1 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you