Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,742
Community Members
 
Community Events
176
Community Groups

This form contains a hidden field that does not have a valid default value configured

This form contains a hidden field that does not have a valid default value configured

2 answers

2 votes
Mikael Sandberg Community Leader Feb 08, 2021

Hi @Karen Marques,

Welcome to Atlassian Community!

If you hide a field on a service request you have to give it a default value. So go to your project settings > request type and select the form you have the hidden field on and then unhide the field, hide it and enter a value. 

I have this issue right now with a team managed project but there are no hidden fields. I have never seen this issue before in team managed project. Could this be a deleted field or maybe a approval field?

I am also facing same issue Request type side showing "This Request Type has no hidden fields." while raising issue time showing "This form contains a hidden field that does not have a valid default value configured"

I'm getting the same issue. In order to try resolve it I made the hidden field unhidden so displays to user. Also made it optional with no value but still get the error. Not sure what else the system could be seeing as a hidden field when there are none showing  2021-11-23_11-58-48.png2021-11-23_12-01-01.png

Found the fix here - https://community.atlassian.com/t5/Jira-Service-Management/all-project-suddenly-getting-hidden-field-error/qaq-p/978411.

The error message pointing out that it relates to the hidden field is misleading in that it is not the hidden field configured on the SM screen above but one of the many other hidden fields configured outside of SM - see the 8 of 29 referenced in screenshot above). If you go and create the issue via Jira Server (not Service Management) the error will be more descript. In my case I had a custom field for CAB approver with a default value of a user that had previously been deactivated. Removing that user from the default list solved the issue.

0 votes

Go to the Project settings of the Service project

then click on "Details", check if the Project lead is someone who has been deactivated and change it to someone who is active

then go to "Internal access" and also check if it is updated.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS

Atlassian Community Events