Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Rule for not including particular email in notification

When a service desk issue is resolved we send an email to the customer, as one would normally do in a service desk project. However, is it possible to make a rule to not send it to a particular customer? The customer in question is not a person, it's a ticket automatically created from another system.

1 answer

0 votes

Hello @Richard Morgan,

Thank you for reaching out to Atlassian Community!

On Jira Service Management projects, the customer notifications are applied to all customers. With this said, it’s not possible to disable the notifications for single customers. 

There is a feature request suggesting the implementation of this ability:

Please, click on vote and also watch to receive updates from the ticket above.

There are workarounds for that in case you are using company-managed projects.

If that’s the case, you can use issue security or move the ticket to a different issue type that will remove the request type (which is what triggers customer notifications). 

If you create a security scheme without the “Service Project Customer - Portal Access” permission, the customers from the ticket won’t receive notifications. 

Kind regards,
Angélica

Thanks but I am not finding this very clear. How can I make sure all issues from one particular user are given a certain issue type? And then with configuring the issue security scheme - I am totally lost. But let's first figure out how to change the issue type.

Hi Richard,

The issue types are linked to request types. 

You said that the ticket is automatically created from another system, so probably it’s always the same request type/issue type that is associated with the ticket that it creates.

If you go to project settings > Request types you can see the issue types associated with request types:

Screen Shot 2021-07-02 at 14.04.51.png

And this is how it shows on a ticket:

Screen Shot 2021-07-02 at 14.06.27.png

The first suggestion I mentioned for the notification to not be sent when closing the ticket, it’s to click on the issue type on the ticket and select another one. Doing that, the request type will be empty and after that, you can close the ticket and the notification won’t be sent. 

I believe that the best option is to use the issue security because it’s easier, it’s necessary just to select the issue security before closing the ticket.

To create issue security, go to Cog icon > Issues > Issue security schemes > Add issue security scheme and create one. 

After that, click on the new security scheme you created and add a Security Level.

Then, click on “Add”, so you can add the groups and people that will have permissions to view the ticket. You need to add the following groups/roles:

  • Project Role (Administrators)
  • Project Role (Service Desk Team)
  • Group (jira-servicedesk-users)
  • Group (administrators)
  • Application access (Jira Service Desk)
  • Project Role (atlassian-addons-project-access)              

Screen Shot 2021-07-02 at 14.51.51.png  

After that, go to the desired project and click on Project settings > Issue security > Actions > Select a scheme > Select the scheme you created > Next > Associate.

Once these steps are completed, on the tickets that you don’t want the reporter to receive the notification, you just need to click on the lock icon and select the issue security:

Screen Shot 2021-07-02 at 15.01.26.png

If you don’t see the lock icon, it means that the field is not on the screen, so go to Project settings > Fields > Click on the Screen Shot 2021-07-02 at 15.07.05.png icon > Search for Security Level > Screen and add to the screens > Update.

Screen Shot 2021-07-02 at 15.00.53.png

Kind regards,
Angélica

Thanks. I followed your instructions, but the lock icon does not appear. The ASP: Kanban screens you have in your screen shot were already selected. I added the Jira Service desk one and clicked update. But the lock icon does not appear.

Hi Richard,

Those screens that appear on my screenshot are from my test projects, you can disregard that.

 Let’s follow other steps to make sure the field is added to the correct screens.

Go to Project settings > Screens and select the screen that contains “View/Edit” and add the Security Level field.

Screen Shot 2021-07-05 at 09.43.14.png

Screen Shot 2021-07-05 at 09.42.11.png

Sometimes there are different screens for different issue types, so please, follow the steps for all of them.

Thank you! Hopefully this works...

Like Angélica Luz likes this

It didn't work. I still got the notification email for one I clicked on the lock icon. Maybe I am missing a step?

I think this is what I am missing:

"If you create a security scheme without the “Service Project Customer - Portal Access” permission"

 

How do I do that?

Hi Richard,

You need to follow the steps of my previous response to create the security scheme.

Note that you as an agent/admin will receive notification, but the customer won't.

This is how it will look like:

Screen Shot 2021-07-07 at 11.15.34.png

To create issue security, go to Cog icon > Issues > Issue security schemes > Add issue security scheme and create one. 

After that, click on the new security scheme you created and add a Security Level.

Then, click on “Add”, so you can add the groups and people that will have permissions to view the ticket. You need to add the following groups/roles:

  • Project Role (Administrators)
  • Project Role (Service Desk Team)
  • Group (jira-servicedesk-users)
  • Group (administrators)
  • Application access (Jira Service Desk)
  • Project Role (atlassian-addons-project-access)  

After that, go to the desired project and click on Project settings > Issue security > Actions > Select a scheme > Select the scheme you created > Next > Associate.

I did do all that, and the emails keep coming through:

Capture.PNG

Are you testing with a portal only account? 

When testing customer automation, it’s important to use a personal email or another email that doesn’t have any admin or agent permission.

If you are using your own admin/agent account, then it’s expected that you will receive the notification, since you are part of those permissions (Administrators, Service Desk Team).

It’s important that the reporter have an account that is only listed as a customer account (Cog icon > User management > Jira Service Management).

I am not sure what you mean by a portal only account, but all requests are made via email. This is from an email address a bunch of people are subscribed to. It doesn't have any admin or agent permission in Jira. Everyone is still getting the notifications as it is still going through to that email address. They are not listed as a customer or anything in Jira, since we are allowing any email address to raise requests. I don't understand how adding people to be able to view the ticket accomplishes the task of the notification email not being sent out.

Portal only accounts are the ones listed on Cog icon > User management > Jira Service Management:

Screen Shot 2021-07-07 at 16.04.47.png

All active customers listed on this page can only view the portal and will only receive customer notifications.

The reporter of the ticket (the customer that created the ticket via email) must be someone that is listed on the page I mentioned above.

Also, it’s necessary to select the issue security on the lock icon before closing the ticket.

I tried adding the email address as a customer but it doesn't subsequently appear in the list.

Is the email listed as an internal user on Cog icon > User management > Users?

Screen Shot 2021-07-07 at 18.04.24.png

If this email is used as the reporter of the ticket, then it has permission on the project, now it’s necessary to find where is it listed to confirm exactly what is the permission of this specific email address.

It is now. I added it to the customers in the project, but it only just appeared in the user management list. Must've taken a while to update. It isn't in the customers list in the project, however, even though I added it. Why do you make this so complicated? Anyway... waiting to test one from that email address.

Still not working. Emails continuing to be sent to the customer I added to the thing you mentioned above. 

Thank you for testing, Richard.

If the customer is still receiving notifications after selecting the issue security, then the specific email address has one of the following permissions:

  • Project Role (Administrators)
  • Project Role (Service Desk Team)
  • Group (jira-servicedesk-users)
  • Group (administrators)
  • Application access (Jira Service Desk)
  • Project Role (atlassian-addons-project-access)    

I can see that you are a site administrator of a Premium site, so to check what is happening in this case, please, raise a support ticket on support.atlassian.com/contact and if you allow, we can access your site and check the issue security configuration. If possible, also add the affected email address so our support team can check why they receive customer notifications when tickets have issue security.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS
Community showcase
Published in Jira Service Management

Atlympic Event: Jira Service Managemnt

Hello Community!  Quick disclaimer: We are running a contest on Community (The Atlympics!) from July 23rd - August 8th of 2021. If you are interested in participating in this contest (prizes! ...

181 views 0 3
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you