Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Request type filter does not work

I have a classic JSD and I have 3 different request types. I had a saved filter where I filter by Request type:

Project = ABCD AND "Request Type" != "12345" AND Status != Done ORDER BY created DESC

but something happened this week in my JSD that now I receive the following message when I run the search filter: 

The option '12345' for field 'Request Type' does not exist.

However, it actually exists! I have tried with all 3 different request types and the search filter does not work anymore. 

Anyone has faced this problem before? How did you solve it? 

2 answers

1 accepted

0 votes
Answer accepted

@Oscar Fonseca ,

If you enter the query and pause at "Request Type" = "

Do you not get a type ahead suggestion list? Did somebody perhaps change the Request Type names?

Also I'm guessing the project didn't change name..?

You mention when you remove the Request Type part of the query you do see the issues with the Request Type next to it? (can you add it as a column and verify?)

Yes, when I pause I see listed the request type options that I have set. So I go ahead and select any of them and then that message appears. 

No, the project hasnt change the name.

Yes, I had previously added the column for Request type and yes, I can see all the issues with their assigned request type. That is why I can export in excel and do the filtering manually there. 

I can also create new issues and select a request type from the options I specified before. So, the problem is only on the search view. 

@Oscar Fonseca

Can you do me a favor and check something?

There wouldn't happen to be a 2nd custom field that was created and called "Request Type"?

It's especially the error message that throws me.. "option xxxx for field yyy does not exist"

When I do a query with a wrong request type my message is completely different. So I'm wondering if somebody created a different field with the same name and the system is just failing to filter on the correct one..

It's a bit of a long shot but I can't think of much else right now.

 

edit:

ok I just tested this myself and created a new field "Request Type" (Select List with some options). When I simply type the query now it fails with the same error.. and with that it breaks both fields for me (cannot search my custom field or the Customer Request Type)

Only when I specify my query with something like 

project = "IT service desk" and cf[10010] = "Get IT help (ISD)"

OR

project = "IT service desk" and "Request Type[Dropdown]" = A

The system is able to make sense of it. I have a feeling there is a new dropdown created which is also called Request Type

I just checked and yes it is correct, there is a dropdown field with the same name!

Double request type.PNG

I am very thankful for your answer. I tried the following: 

project = "ABCD" and cf[10010] = "12345" and the query worked!

So, should I change the name of the dropdown "Request type" field? 

Dirk Ronsmans Community Leader Oct 09, 2020

Well you can choose to:

  • Change the queries that use the Request Type

OR

  • Change the field Name

I would change the name of the dropdown field if it is an option, that might be less confusion.

0 votes
Jack Community Leader Oct 08, 2020

i'm not seeing this at all. can you provide your actual query here? Also, I would be interested if you created the query under Basic mode does it work and if so if you then click on "switch to JQL" how does it compare to the original.

I wont paste the real Project name and Request types for NDA reasons. I copy pasted the JQL and replace them with "ABCD" and "12345". 

It does not work on basic mode, it says: switch to advanced. Bare in mind that this is a classical JSD project, I already tried with issuetype and I face the same problem. 

Request type.PNG

If I delete from the query "Request type", I can see all of the tasks. But If I want to order them DESC or ASC by request type, it wont work either. I cant click over the column for Request Type. My only option so far is to export all the issues in excel and delete the issues that are the request type that I do not need, which is manual work that I want to avoid. 

Jack Community Leader Oct 09, 2020

wait... Request type is actually "Customer Request Type". can you please try that?

Dirk Ronsmans Community Leader Oct 09, 2020

@Jack

I had the same idea initially but seems that on cloud it is called "Request Type"..

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS
Community showcase
Published in Jira Service Management

Why upgrade to Jira Service Management Premium?

We often have questions from folks using Jira Service Management about the benefits to using Premium. Check out this video to learn how you can unlock even more value in our Premium plan.  &nb...

235 views 1 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you