Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Post upgrade of Service Desk to v.4.13.7 the User & Roles section went blank. How to fix that?

I have upgraded Jira Service Desk/Jira Service Management from v.3.12.0 to v.4.13.7 and completed re-indexing in a sandbox environment. Everything looks fine except the 'Users and Roles' section under 'Project Settings'. This page went blank/empty.

Can someone please guide on how to debug/troubleshoot this problem to fix?

Appreciate in advance!!

1 answer

0 votes

@Gunasekaran Subramanian -

Is your sandbox env a clone of your prod env with content?  You should also check to see what you have via Jira Administration > User Management in your sandbox env.

Best, Joseph Chung Yin

Jira/JSM Functional Lead, Global Infrastructure Applications Team

Viasat Inc.

@Joseph Chung Yin , Thank you for the quick response. The user management section does not have any impact.

The sandbox environment was not an exact replica of production in terms of projects/issues in it; but it was a working copy - still a working copy with an exception of  Users and Roles section issue under project settings.

Thanks.

What do you mean by blank/empty?  Are you stating that all the project roles in used for the projects are showing with 0 membership?

Best, Joseph

Here is a similar issue that I found, maybe it will help you to investigate - https://community.atlassian.com/t5/Jira-Software-questions/After-upgrade-to-8-7-1-Project-Settings-Users-and-Roles-is-blank/qaq-p/1338953

From the above reference - Can you try the same operation via a different browser app?  (NOTE that IE is no longer supported as an app for Jira/JSM).  Lastly, does the same issue happens for all of your projects in your sandbox env.

Best, Joseph

Thank you. Let me go through the link. Please find the screen shot of what I could see - when I select 'View user Roles' (or) Users and roles option under Project settings.

empty-user-roles.PNG

I tried this in Chrome and Edge browsers. Facing same issue.

This problem is happening on all projects. The link is pointing to make changes in the log configuration at log4j properties. So the aim is to analyze if we could find anything from the logs?

I have checked at atlassian-jira.log and atlassian-jira-security.log as well. No error messages are available in both logs while accessing the specific page. 

Thanks..

In this case, I would recommend you to submit official support case with Atlassian Support Team, so they can support you further.

I would like to know what was the cause and solution once your issue is resolved by contacting Atlassian Support directly.

NOTE - Atlassian server support will end soon (announced sometimes ago).  I assume you are on Data Center right? After server support is ended, Atlassian will only provide support against Data Center and Cloud envs.

Best, Joseph

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
4.13.7
TAGS
Community showcase
Published in Jira Service Management

Atlympic Event: Jira Service Managemnt

Hello Community!  Quick disclaimer: We are running a contest on Community (The Atlympics!) from July 23rd - August 8th of 2021. If you are interested in participating in this contest (prizes! ...

71 views 0 0
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you