Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,363,616
Community Members
 
Community Events
168
Community Groups

Jira not starting with error "We haven't been able to start all the required system plugins"

Hello,

Since some weeks, Jira is unable to start with following error message :

"We haven't been able to start all the required system plugins"

Full error message is attached to this request 

 

I already tried to fix this error with the following KB :

https://confluence.atlassian.com/jirakb/jira-startup-fails-with-message-that-required-plugins-are-not-started-254738702.html

 

SELECT * FROM pluginstate where pluginenabled = 'false';

The above SQL query returned this result : 

com.onresolve.jira.groovy.groovyrunner:jsd-canned-comment-loader

I removed the entry and after this Jira startup worked but after some days Jira failed to start and the entry come back again. 

I don't find the plugin jsd on my installed plugins which seems weird to me.

Do you have any idea ?

 

Thank you for your support

Best regards 

 

1 answer

0 votes

Has something changed before you started getting the error, e.g. version update, new plugins, or even plugin version updates?

 

When Jira starts, it prints the plugins it loads in atlassian-jira.log - and there is a timeout threshold during which Jira expects to load all plugins. If you have a plugin in there which cannot start and blocks the plugin loading, then you get the error you describe.

I'm curious whether you will find com.onresolve.jira.groovy.groovyrunner pluginkey in the log

 

com.onresolve.jira.groovy.groovyrunner belongs to Adaptavist ScriptRunner for Jira

jsd-canned-comment-loader is a module of it named "Canned comments resource"

 

On a local instance I'm checking we have this module disabled, but I can't tell you if it came disabled by the plugin or whether somebody has disabled it for some reason at any point.

 

What I do suspect however is that if it's working fine locally as disabled, it's not the cause of your problem - there probably is something else being stuck loading, consuming your plugin loader timeout threshold, which ends up that Jira doesn't get to load the necessary plugins in time -> throws a startup error.

Try to look in the log if you find a hint for which plugin fails to load or times out.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events