Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Jira Service Management is licensed but not currently installed

I have this message after the upgrade to the latest Version 8.21.0

However, I cannot install the Service Desk. When I click on "Install" button, I get the following error message:

"An unexpected error occurred. Refer to the logs for more information.", but there is no log file showing any error.

My License was expired and I tried to renew the License by uninstalling and reinstalling it.

any suggestion?

 

2 answers

0 votes

Try the install again, and read the logs as the install is running.

On the server, the file you need to watch (I usually use "tail -f" before clicking on the action that is failing) is <jira home>/logs/atlassian-jira.log

the installation was done without any issue or problem

Excellent news!

It was probably a network hiccup or something that broke it the first time round!

No!, what I meant was, the Installation was without any issue, however, the problem occurred.

I have restored the whole application (incl. Database) from my backup and tried to renew the license in 8.12...

even there the license renewal hangs...

Is there currently an issue with Atlassian Server?

Um, your story has changed now.

In your question you say "When I try to install I get this error message".  Now you say "the installation was without any issue".

Which is it?  What action are you performing, and what is the error or problem with it?

ok, sorry.. may bad in explanation...

I have updated an existing installation and the the upgrade process (Installation) went well without any issue.

However, since my License was excited, I have tried to renew the license by editing the License entry and copy/pasting the new License key into it...

this didn't work and it was waiting forever to accept the license.

Then I tried to delete the License and re-Install it, there is when I get the error and no logs to understand where the problem is...

So, the wording "Installation" was related to the "Service-Desk" Module in License-Area.

So you are not using the "install" button at all, you are just pasting a new licence key into the licence field and using "update licence"

And the problem is that it just churns, not completing the association with the new key?  What happens if you refresh the page?

Actually, in the first attempt, I have uninstalled the License and Service Management Module, which didn't work but probably corrupted the DB.

After that, pushing the "install" button to reinstall the Module didn't work at all and no log was generated.

Now, I have reverted everything to the start (using my backups) and reinstalled the application. Now, I have the old License and the Module in the area Application->Version&License, but I cannot renew (Edit) the License.

A reload or refresh shows the prior page not being updated.

What happens when you push the "update licence" button after pasting in a new licence key?

actually nothing! The area grays out, the application gets stuck and the gauge goes from left to right... and that forever!!!

Hmm.  How long have you left it churning?  More than 20 minutes? 

It should time out before then, and give us an error in the log, but if it's not timing out, there's something totally breaking in the licence check (it should be almost instant) which should be throwing an error into the log and then failing or locking up.

If there's nothing in the logs when you click "update licence", the only option you've got left is to raise it with Atlassian.

ok, Problem solved. It was, as expected, the Atlassian Server not responding to the License inquiries. Today, I checked again and everything worked like a charme.

 

Thanks for your help

@Foroud Saraji 

 

You don't need to uninstall the product to update your licenses, just go to my atlassian and get the license keys and change them in your environment by going to "Applications".

But for your case, as there was a tool version update, I faced something similar and it was because we were using insight and he made a change in the database.

Had to contact Atlassian support to resolve.

To help, create a support zip log file.
Go to "System";
Click on "Troubleshooting and support tools";
Then click on "Create support zip", and then on "Create Zip".

Jira will give you a complete log file that can be useful for Atlassian staff to help you with.

Having the file, contact the staff here: https://support.atlassian.com/contact/#/

 

Sometimes some apps make changes to the database and version updates are impacted with these apps

Hi Fernando,

we are not using anything else than Jira Service Desk itself and this happened after the upgrade to the Latest Version.

Since this is a starter License, I am not able to create a ticket on Jira Support at all.

any suggestion?

@Foroud Saraji 

 

You really can't identify any error lines downloading the ZIP in the Troubleshooting and Support tools tab?

This would help you understand if the problem is in the environment or in the database.

Try this or when the error you indicate appears, click on "see details" to see the error logs.

Usually the Server presents these logs as soon as the problem happens.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
8.21.0
TAGS
Community showcase
Published in Jira Service Management

Next level incident management in Jira Service Management

Hello Atlassian Community! We’re thrilled to announce some exciting changes to incident management in Jira Service Management Cloud, in order to give your teams extra muscle during incidents, and ...

1,668 views 21 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you