Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Jira Service Desk 4.11.0 customer portal not loading in Safari browser

We have verified that our Safari users are not able to browse to the Jira Service Desk portal. Where this seems to be working fine in other browsers.

We also are able to use Safari to view the agent view. 

4 answers

0 votes
Ismael Jimoh Community Leader Oct 19, 2020

Hi @Matthew Gaffney 

I will suggest doing the following:

  1. Logout of Jira
  2. Access the customer portal link in Safari
  3. Login back to Jira proper as an agent
  4. Create a support zip noting what time you experienced the error
  5. Check your atlassian-jira.log if any error is returned at said time.

If you can reproduce the problem then:

  1. Check jira.atlassian.com if an issue about this has been raised.
  2. If not, raise a ticket providing more information about the problem. If there’s an error in your log, add it to the ticket.

Regards.

0 votes

Does safari have something similar to a developer console?

 

I suggest opening that and seeing whether the page throws any errors. I’ve had something similar with IE and scriptrunner behaviours. 

Also, if your environment allows, try disabling addons to see if any recent update causes it. 
did u update to 4.11 recently?

I did use a JavaScript developer console option in Safari. The errors there that stood out were:

[Error] ReferenceError: Can't find variable: responseData

[Error] Unhandled Promise Rejection: ReferenceError: Can't find variable: responseData

[Error] Failed to load resource: the server responded with a status of 503 () (ui-portal.js.map, line 0)

Dirk Ronsmans Community Leader Oct 20, 2020

Do you also ge that when you disable the app?

Otherwise I'd still send it to the vendor :)

Further troubleshooting on this within our team and we've identified this to be an issue with the update we just applied for the HelpCenter Corrector app. 

From what I can tell so far is the User Interface for that app hasn't changed, so it's not clear to me what has changed to make this stop working in Safari only. 

*EDIT*

We also tested this in our Demo environment where the plug in doesn't exist and the issue remains.

That’s what I assumed. 
Open that developer console and submit a bug with them. 
(could be a known issue)

 

u can always downgrade the app to verify

Like Matthew Gaffney likes this

I've reached out to them. Thank you for the suggestions. 

We've ruled out the app. We've submitted an issue to Apple as this version of Safari had other bugs, and so far as we can tell the issue started after the latest version of Safari was installed on our computers. This update happened around the same time as our last JSD update too... so it makes it harder to pinpoint things. :-) 

We have just a few Apple users, and not all of them use Safari, so it's possible this has been occurring for a couple of weeks already now. 

EDIT!!  @Matthew Gaffney 

We were having he exact same issue.  Disabling the HelpCenter Corrector app did fix things for us in Safari on a Mac and on Phone!

I realize you tried this and it didn't work for you but I'd encourage you to try it again as we had what sounded like the exact same problem and we had upgrade the app just yesterday when the problems started.

 

Your post really helped us solve it. Thanks and wishing you good luck!

 

dany

 

Glad things worked out well for you. We're still seeing mixed results. Disabling HelpCenter Corrector does seem to help, but I can still reproduce the error at times where HelpCenter Corrector is disabled or in instances where it was never installed. 

We have been in talks with Apple and Atlassian. If anything I hope our talks with Apple result in some sort of diagnosis of how Apple renders the display in their browsers because this seems to be working fine in other browsers. 

If there seems to be something Apple discovers we are doing to cause the issue, that will be helpful as well. 

Sorry to hear you still have issues.

As mentioned, we have the same version  running on Server on-prem without issues in Safari since removing Corrector. So my guess would be this plugin and other plugins are the cause as that's likely where we differ.  I'd try uninstalling all plugins in a dev env, if you can.

All the best.

Always a good idea when you encounter these issues.

Try going in to Safe mode and enable each app on its own. 

  • enable
  • test
  • disable
  • next one..

Depending on the amount of apps of course this can be an annoying process but you should at least find each app that is causing mayhem on its own!

https://confluence.atlassian.com/upm/disabling-and-enabling-apps-273875716.html#Disablingandenablingapps-Disablingorenablingallapps(usingSafeMode)

@Matthew Gaffney I alerted the makers of HelpCenter Corrector to the issues that @Danny Brown and I encountered and they are looking into it on their end as well. I hope you come to a quick solution!

Like Matthew Gaffney likes this

Thank you! I reached out to them via email. I'm waiting to hear back. 

Like Troy Chaplin likes this

Great, I also sent them a link to this issue as well so they would be aware of it

Like Matthew Gaffney likes this

@Troy Chaplin / @Danny Brown did either of you get a solution from HelpCenter Corrector? They haven't responded to me at all, which seems super strange to me. 

Thank you

Sorry @Matthew Gaffney I haven't heard anything since they thanked me for reporting the error. I emailed them instead of setting up that telegram app they prefer. Not sure if that makes any difference.

I emailed them also in place of using the telegram app as well. Glad I'm not alone there. :-) 

I was able to reproduce this error this morning in Safe Mode on our Demo environment where HelpCenter Corrector wasn't installed.

HelpCenter corrector may not be the cause of the issue, but the app certainly makes things worse. With the app disabled or in safe mode it takes a whole lot more attempts to see this fail. 

I've gotten this to fail by:

  • simply logging into the portal with an account that only has portal access. 
  • logging in as an agent and selecting the view customer request button
  • logging in as an agent and typing the address to the customer portal

The third option is how I got this to fail in Safe Mode this morning. 

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
4.11
TAGS
Community showcase
Published in Jira Service Management

Why upgrade to Jira Service Management Premium?

We often have questions from folks using Jira Service Management about the benefits to using Premium. Check out this video to learn how you can unlock even more value in our Premium plan.  &nb...

189 views 1 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you