Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,890
Community Members
 
Community Events
176
Community Groups

How to remove weekends from SLA Reports

I am currently attempting to display SLA Time to First Response and Time to Resolution within the reports feature without displaying "Saturday and Sunday" as we don't work those days. Is this possible? 

I saw that I can choose a custom range but only for a certain week but that does not work well when I want to put it as a dashboard widget. 

3 answers

1 vote

Hi, @Phillip Orange

Is the request just cosmetic or is the fulfillment SLA running even on days when you don't work?

@Édpo César 

Yeah the issue is it's counting Saturday and Sunday affecting the metrics. 

Good.

So the first thing that you need to do is remove the wekeend in your SLA, after that your next reports will be heathly.

Go to:

1. Project Settings
2. SLA
3. Choose resolution SLA and observe what is the calendar used.
4. Go to calendar and remove the sarturday and sunday. 

Captura de tela 2022-01-19 101430.png

Thank you for the response and tip, I checked the calendar and both Saturday and Sunday are not checked. So will Saturday and Sunday still appear on the report even though they are not on the calendar? 

Screenshot_7.png

Phillip, I didn't get it.

Weren't they already unchecked or are you unchecked now?

The change only will appear in the next report automatically. 

But you can creat a JQL filter and exclude the ticket on theses days that you don't want to.

An example of this JQL filter: project = "Project name" and issuekey not in (DEV-437, DEV-436).

Yeah the days were already unchecked, I made no new changes to the calendar. I attempted to create a JQL filter but I haven't found one that really works. Thanks for you help once again. 

@Phillip Orange , if the days were already unchecked, and your SLA is still running on the weekend, there is something that you're missing there.

I recommend you check it out this article about de SLA and this article about JQL language.

Jack Brickey Community Leader Jan 19, 2022

can you share a report? I suspect that the SLA is discounting the weekends correctly. Maybe it is simply an interpretation of the report since the weekend will still display in the report.

2022-01-19_11-45-05.jpg

I have the same Issue, @Jack Brickey 

In the calendar, Sat/Sun are excluded. In the report, those are marked as 0% - So my question would be: How can I exclude non working days from the report? Otherwise the reps are useless. 

Does someone have a solution for this?

Regards

Rainecalendar.JPGweeknd.JPG

Like Andrej Grimm likes this

Did anyone figure this out?  I am also having the same problem as @Rainer Daller and @Phillip Orange .  The averages are way off because it counts those 0's

Like Rainer Daller likes this

Hi @Erin Blomert , sorry. No solution for this. So we do it in good old excel. 
regards Rainer 

Sorry to hear it, thanks for the response.

I've started switching mine to week view if I need averages, but it doesn't really show the whole picture!

I thought i had the same issue, but try including and excluding the weekends (or non work days) in the report date selection and compare the results. 

The non work days are displayed as 0% but do not count into the overall %.

Hi,

 

I've noted that when you take the average of each day it will not line up with the report's displayed %, even if you manually filter out the weekends.

However if you take every loose ticket and calculate the average over that then it does line up with the % displayed in the report.

 

So while it is (to my knowledge) not possible to hide these dates on the reports, if your date range on your SLA's is set correctly you will get the right numbers.

 

Hopes this helps to clear a few things up.

Hi @Édpo César 

i have the same challenge as @Rainer Daller and @Phillip Orange . is there perhaps a solution or idea here?

 

Best regards

Andrej 

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events