Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,360,921
Community Members
 
Community Events
168
Community Groups

How do I resolve the following error: "Attachment" field isn't present on the issue view screen.

I'm still fairly new to Jira. I'm trying to use deep clone in my workflow to transition tasks from project to project while keeping the attachment throughout. Although I have the post function set up correctly, it's still not working. I went to check that the field "attachment" is available on my target project, but I'm getting the error: 

"Attachment" field isn't present on the issue view screen.

How do I resolve this?

 

 

1 answer

1 accepted

2 votes
Answer accepted
Mark Segall Community Leader Aug 11, 2022

Hi @Aida Johnson 

I went to check that the field "attachment" is available on my target project

Can you confirm that you checked the Create/Edit/View screen(s) for the target issue type?  The error message seems to indicate that it's not on the actual screen configuration.

Screenshot 2022-08-11 160959.pngSo the attachment gets added from the previous board but never clones to the new board due to this error. 

When I clone it manually it works just fine but when I add it to my workflow in order to automate, it doesn't work.

Mark Segall Community Leader Aug 11, 2022

I believe this is because Deep Clone is using a different backend function to create the clone than the native Jira clone.  Deep Clone is making a series of API calls which probably includes creating an issue.  When creating an issue via the API, all fields you wish to have populated must exist on the target screen, including attachments otherwise it will throw an error like this.  

Hi Mark.

I just want to thank you for your help. I tested out a few things and realized I was doing too much. I wanted to automate this in a way that the clone was created and moved to a new project AND delete the original issue that's left in the previous project. It would clone the task but end up deleting the attachment. I'll continue to play around until I get things set up how I want them.

Thank you again!

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS
Community showcase
Published in Jira Service Management

An unofficial way to monitor a JSM mail handler for errors

...eturns true if any content is returned for the webResponse.body.data.first s...

682 views 3 20
Read article

Atlassian Community Events