Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
Level
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Automation works only a couple of times

I have a very simple automation rule: when a linked issue is created, send email to reporter. Something weird happens, because it works only a couple of time and then just stops. There are no log entries in audit log, no error messages, nothing. Only thing which I have noticed is, that when publishing a change the rolling line stays circling over Rule succesfully published-icon. After that, when I recreate similar rule, it again works a couple of times and then stops. Any ideas?

 

1 answer

1 vote

Hi @arir,

Can you check the rule's audit log? It will help us understand if you get an error or if just nothing happens.

Is it possible the rule is triggered by another one? If so, you need to check the "Allow rule trigger" option:

Capture d’écran 2021-02-25 à 13.45.31.png

Hope this helps,

- Manon

Here's my audit log. After the successful execution of the rule, I did some text changes in the email to be sent. No errors, no nothing.

jira-audit-log.png

Oh, and this is not triggered by another rule.

Some more info: if I create a linked issue into another project in Service Management -project, the rule is executed ONCE, If I create another linked issue, the rule is not executed anymore. If I link an existing issue in another project, the rule is executed every time. I found a workaround: I activated the rule in destination projects, so those projects react to linked issue creation, not Service Management -project. A bit confusing, but now it works like I wanted.

Like Manon Soubies-Camy likes this

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS
Community showcase
Published in Jira Service Management

Announcing Mindville Insight is now part of Jira Service Management!

Hello Community! We’re excited to announce that Mindville Insight’s asset and configuration management capabilities will now be integrated into Jira Service Management Premium and Enterprise plan...

751 views 12 15
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you