Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
Level
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Automation comment treating comment as is from customer which starts our "Respond to Customer" SLA?

Automation auto comment treating comment as is from customer which starts our "Respond to Customer" SLA.

Need the automation user to be treated as a Service Desk Tech.

Tried blocking SLA, Adding as Admin and adding to our team AD group.

Nada.

Please help!

Thanks!

1 answer

1 accepted

0 votes
Answer accepted
Jack Community Leader Sep 26, 2017

@Ian Johnsen, i'm a bit confused by what you are trying to do. There seems to be two parts here? First you want to create an automation rule that spoofs the customer (reporter?) and adds a comment. The second part is that you want this comment to start the "Respond to Customer" SLA timer. Do I have this correct? Unsure what a 'customer comment' would equate to starting the SLA timer.

I am assuming that you don't simply want to use 'issue created' as the starting point for the SLA? If so can you elaborate as to when the automation rule would run, placing the comment into the issue?

Maybe i'm off base on what you wish to accomplish here. If so please point me in the correct direction.

Hi @Jack,

The case is we have a Helpdesk Bot that is adding a comment once a ticket in at a point where the user needs to close the ticket.

When the Automation triggers and adds a comment it is restarting an SLA for responding to a customer.

So it seems that Service Desk is seeing our Helpdesk Bot as a service desk user even though it is listed as a service desk agent. 

Heya @Jack!

Sorry probably all me for not providing enough info!

 

So here is the automation:

WHEN:

->Status Changed

IF: 

-> status = "Reporter Review" 

THEN:

-> Send email

-> Add Comment

 

Please checkout the screenshots.

Please let me know if this helps.

Thanks!

Screen Shot 2017-09-26 at 10.04.59 AM.pngScreen Shot 2017-09-26 at 10.05.09 AM.png

Jack Community Leader Sep 26, 2017

ah ok. i think i'm understanding better. That said, i'm trying to establish a well formed answer for you.

I'm thinking what we need to do here, if possible, is to amend the SLA in a manner that excludes the bot. Can we have a look at your SLA? BTW, server or cloud?

Server. I tried blocking this user with SLA like some issue types, but no dice :/

Jack Community Leader Sep 26, 2017

is the comment required? it appears there isn't an option to add an "internal" comment, at least in cloud it is "by customer" or "to customer". could you simply delete the comment from the automation? isn't the status of "Reporter Review" sufficient?

Actually might not have set the SLA blocking for that user correctly now that i think about it. What would the JQL be?

 

Screen Shot 2017-09-26 at 10.23.53 AM.png

Nah we need to have the comment stamped on the ticket. I actually need to modify the wording, but that's besides the point haha.

Basically, Service Desk is treating "IT Helpdesk user" as a customer. Possible to make a Service Desk Team member or block this user from SLA (preferred)? Tried adding this user to our Service Desk AD Group and Adding as "Administrator" and "Service Desk Team" under "Users and Roles"

Jack Community Leader Sep 26, 2017

can you provide the screenshot of actual automation? Are you sure you have the comment listed as "internal". If so I would assume that it would not trigger the sla. 

Mmmk maybe thats the issue. I do have set to public. BUT do want all people on the ticket to see comment. Perhaps my understanding or Public vs Internal is a little off here. Any input in this? Thanks so much!

Jack Community Leader Sep 26, 2017

that is it for sure. your SLA is kicking in at comment by customer and stopping at comment for customer. If you want them to see that comment AND continue the timer then you will need to try to add a qualifier to the SLA. 

if the issue is closed please accept the answer above.

Got it. I will test with Internal comment.

Thanks!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

Announcing Mindville Insight is now part of Jira Service Management!

Hello Community! We’re excited to announce that Mindville Insight’s asset and configuration management capabilities will now be integrated into Jira Service Management Premium and Enterprise plan...

751 views 12 15
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you