Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Automated Comments Not Working

Using the new Jira Automation Rules, we've setup two automated comment updates; 

  • Prompt Customer For a Comment 
    • Prompt them if they haven't updated a ticket in e.g. 5 days 
  • Close due to inactivity 
    • Update the ticket with a comment and close it due to no response in e.g. 14 days 

We have separate groups for our clients for privacy and whilst the above transitions to "Closed" are working without issue, the automation isn't adding comments on certain service desks and we're getting this error message: 

"Error adding comment to issueGroup level visibility has been disabled. (commentLevel)" 


I've looked at quite a few articles but haven't been able to find a solution to this, any suggestions / advice appreciated 

1 answer

1 accepted

Hi @Ana Sooter

 

Looking for your error I think that your instance don't have comment visibility enabled for Groups.

I would recommend to check if your instance has Group & Project Roles enabled for Comment visibility, see below how to check this:

  • Check under JIRA Settings > System > General Configuration for "Comment visibility" make sure it's set to "Groups & Project Roles" and not "Project Roles only"

https://confluence.atlassian.com/jirakb/add-restricted-comments-on-jira-962353957.html

I hope this fixes your issue!

Hi @Italo Qualisoni _e-Core_ 

Thank you for this update, I've made that change but I'm now getting a different error message: 

"Error adding comment to issue You are currently not a member of the group: XXXX - Client. (commentLevel)

The settings for posting the comment are: 

  • Share with Customer 
  • Comment visibility -> XXXX - Client (Group)

Concerned I've missed a step or haven't set something up correctly

Hi @Ana Sooter ,

So you can only set comment visibility of groups you belongs to.

The default rule actor is the Automation User it this user is not part of the group you want to use.

You need to change the rule actor to some user that belongs to the Group you want to set customer visibility.

Like Ana Sooter likes this

Hi @Italo Qualisoni _e-Core_ 

Do'h - that makes sense, thank you so much for your help! 

I'm glad I could help you!

Enjoy your holiday and "Feliz Natal!"

Like Ana Sooter likes this

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS
Community showcase
Published in Jira Service Management

Why upgrade to Jira Service Management Premium?

We often have questions from folks using Jira Service Management about the benefits to using Premium. Check out this video to learn how you can unlock even more value in our Premium plan.  &nb...

182 views 1 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you