It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Why are Service Desk issues showing up as "Incorrect request type" customer view? Edited

roymeo Apr 13, 2017

Some of the issues in our JIRA Cloud Service Desk are displaying "Incorrect request type" when trying to view.  Even when I, the admin, try to view them I'm getting this error.

My issues show up in the internal view page:

https://-my-id-here-.atlassian.net/browse/VS-534

but I can't see it here

https://-my-id-here-.atlassian.net/servicedesk/customer/portal/1/VS-534

 Yet some other issues such as VS-532 and VS-540 appear in both views.  None of the others between those 2 appear for the customer portal view, but they're all, mostly, auto-filed issues created via email submissions.

Now that I have a response below to check out the "Service Desk request" / "Request type" which was "No match" for the ones that won't view...

I just created a test item via the internal Create button, it comes up as a "No match" upon creation.  Some have been created by email submission.

4 answers

1 vote
Adam Risoldi Apr 14, 2017 • edited

Hey I ran into this same issue and have appeared to find a fix for it. If you look at the ticket from the internal view page you should have a property for "Request Type" under "Service Desk request". My issue was that the field was blank after populating it with a value I was then able to view the request from the customer portal.

Also looks like they're is a suggestion to fix this for issues created from the admin side of service desk. JSDSERVER-2385

roymeo Apr 14, 2017 • edited

That does look like the problem.  Now to go see if I can mass detect and mass change them all...

 

Nope.  Have to step through them all and hand tweak them.  Weird.

0 votes
Werner Meyknecht Oct 11, 2017

Atlassian!

I would be very interested in that too.
Why is the question not answered?
It's April 2017!

0 votes
Michael Green May 09, 2018

I'm still getting this problem.  Why have they not fixed it ?

0 votes
Heidi Bellio Sep 20, 2018

I have the same issue. 

Issue created in customer portal says: Incorrect Request Type, no result screen. but issue is there

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Jira Service Desk

4 changes to queues and issues you don’t want to miss

Hello Atlassian Community! I'm Tania, a Senior Product Marketing Manager for Jira Service Desk Cloud! I'm excited to announce some exciting improvements coming up for those who work with queues and...

606 views 9 13
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you