It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Share as comment button is grayed out

Created KB in Confluence Linked to the Service Desk. 

In Confluence article is Unrestricted. But when trying to use this article in the ticket in SD - its restricted and Share as comment button is grayed out.

Article restricted.PNGShare as comment Screeenshot.png 

 

Anonymous is enabled and has view rights in Confluence.

 

1 answer

0 votes

Hi there,

Is the page a child of a parent that has restrictions? Restrictions are applied to child pages from a parent and this could cause it.

Shannon

Shannon,

I'm experiencing the same issue. None of the parent pages have restrictions and I have verified that the page can be viewed without logging in. 

The share as comment button is still locked.

Thanks,
-Justin

Hi Justin,

Is it only that page, or other pages in the same space? 

Can you show me how the permissions are in your Service Desk settings, as well as the Permission Settings for the space in Confluence?

There are NO restrictions on the page itself, correct?

Regards,

Shannon

Hey Shannon,

It looks to be all articles in the space. I have attached screenshots of what it looks like and our settings.

Screen Shot 2018-03-01 at 2.56.47 PM.pngScreen Shot 2018-03-01 at 2.57.03 PM.pngScreen Shot 2018-03-01 at 2.57.26 PM.pngScreen Shot 2018-03-01 at 3.04.04 PM.png

Hi Justin,

I think it might be related to this issue:

If a user (e.g. a JIRA user) is not licensed to use Confluence, they cannot view any Confluence content (from JIRA or Service Desk for instance) - even if that content is available to anonymous users. They currently have to log out before they can see the content. Customers have also asked for anonymous, read-only access for authenticated users that are not coming from a JIRA User Directory.

Have you also given the Service Desk users access to this space via the project settings

Select Project settings > Knowledge base to create and link a Confluence space to your service desk project. You can also use the knowledge base settings to define who can create and view knowledge base articles. 

For this, you want to make sure the All active users and customers setting is chosen for permissions.

Kind regards,

Shannon

Shannon,

I do not see a radio button for "All active users and customers" like the instruction link you attached. Here is what I see:

Screen Shot 2018-03-02 at 1.31.38 PM.png

Hi Justin,

You would need to first remove anonymous access from the space, and then it will provide you with the option to ONLY allow licensed users. 

Can you give that a try?

Regards,

Shannon

Shannon,

Ok. Once I went into Confluence and removed the anonymous setting I got the additional settings. I selected the option you suggested, but I am not presented with this information when trying to share a KB article and our knowledge base is no longer accessible publicly.

Screen Shot 2018-03-05 at 8.11.16 AM.png

Justin,

So to verify, you removed the anonymous setting, and now the setting is selected that says "All active users and customers".

Now you've logged into Jira as a Jira-only user, and you are greeted with that error message when viewing an issue in the Service Desk which would normally display articles from the linked Confluence space, correct? 

Could you confirm your Confluence and Service Desk versions?

Regards,

Shannon

I have the same issue, articles are standing as "restricted" and cant be shared with customers from JIRA.

We have the same issue.

Hello @Christoph@Normann P. Nielsen -Netic-,

I apologize for the delay on this as I hadn't seen your reply.

The issue on this case originally was that the article was anonymous, but when you're logged in as a Jira user you aren't able to see it. This is because when you are logged in as a Jira user, Confluence doesn't consider the user to be anonymous, but unlicensed, and therefore doesn't give permission to show the article.

Again, the feature request below:

  • CONFSERVER-30161 Allow unlicensed, authenticated users to have anonymous read only access

If this is not the case for your article, then I would advise you to reach out to Atlassian Support, or to raise a new question with your specific situation. Then we can take a look and see what might be causing the issue on your end.

Thank you for your understanding!

Regards,

Shannon

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted in Jira Service Desk

Tell us how you've implemented Change Management

Hello Community 👋, I'm a product manager at Atlassian, looking at improving change management capabilities across our products. In particular, we're looking at bridging the gap between Dev & ...

299 views 0 6
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you