Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SLAs and Automation: "Respond to Customer" button vs comment and "Share with Customer"

Our agents have historically always written any messages to the customer in the comments field and then chosen the "Share with Customer" option. They have never used the "Respond to  Customer" button at the top. But we have found that the "share with customer" comment workflow does NOT transition the status to "waiting on customer" so the SLA time will pause.

We need to start tracking and reporting on our SLAs but this is really affecting our times. I've tried a number of variations on customizing the automation rule but I cannot get it to stop the clock. Below are my current configurations.

Rather than trying to get everyone to completely change the workflow they've had for 3 years (which I know wont be successful) does anyone have any suggestions? Or has anyone else ran into this?

 

Automation- Transition on comment.jpgSLA Service Desk.jpg

 

1 answer

0 votes
Jack Community Leader May 16, 2019

you can change your Automation to do whatever you like. However, I prefer to use the Respond to customer to result in the transition to the Waiting Customer status for SLA pause reasons. There are times when my agents want to simply provide a comment to the customer w/o transitioning it since they don't necessarily need the customer to do anything.

That's what I thought but for some reason I cannot get it to transition when using the "Share with customer" comment no matter what I do. I can see it errors out in the log but I cannot figure out why its happening? And none of the logs I can find on the server provide any more insight that what this shows: 

Error automation transition.jpg

 

Jack Community Leader May 16, 2019

here is what works for me (cloud). This will transition an issue that has been moved to Waiting for customer when the customer comments. An issue moves from Waiting for Support to Waiting for customer via the Respond to customer transition.

transition on comment.jpg

The transition back to "Waiting on Support" when a customer replies does work its just the transition from support to  "waiting on Customer" that doesn't.

You said you have cloud so I'm guessing there isnt the same sort of detailed logs that are available on server?

But do you, or anyone else know where I may be able to find out why the transition is failing? 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Asked in Jira Service Desk

Calling all Insight users, we need your help!

Hello Insight users,  As part of our (Mindville's) acquisition by Atlassian, our training team is looking to build some new Insight training materials. It would really helpful if you can ...

157 views 1 0
View question

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you