Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Jira Service Desk Queue page slow to render

Sverrir Tynes _Origo_ February 28, 2018

After editing several Service Desk projects to Software projects the Queue page is slow to render displaying a spinner. I can not see anything in the logs or the browser console.

We are running JSD 3.10.2 on JIRA Software 7.7.2

Any suggestions on how to troubleshoot this behaviour?

1 answer

1 accepted

2 votes
Answer accepted
Andy Heinzer
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
March 5, 2018

Could you clarify the steps taken here?  Did you change the project types on these same projects where you are trying to access the Queues?

While you can change a project's type in Jira, when you change from a Service Desk Project to a Software project, there are certain functionalities that I would expect to stop working.  When you change a project like this to a Software project, then the Service Desk specific features, such as SLAs, the customer portal, and the agent queues among others, will actually not work anymore.   These are Service Desk specific features, as such the projects have to be Service Desk project for you to have this functionality. 

It might have been possible to do this with older versions of Jira Agile and Service Desk, but I know this cannot be done in any of the Jira 7.x (Service Desk 3.x) versions.

Sverrir Tynes _Origo_ March 6, 2018

The queue are for Service Desk projects as shown on the attached screenshot. Please inform if this is a known issue after upgrading JIRA and Service Desk from JIRA 7.2. Sometimes the issues (alway very few as we are in the testing phase) are displayed but more ofter the spinner hangs and the issues are not displayed in the queue.

service-desk-spinner.png

Andy Heinzer
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
March 6, 2018

Ah, ok.  Thanks for clarifying.   I would be interested to see if you can generate a HAR file when loading this page to see if we can see specific errors in the browser session or other problems in the network requests being made when trying to load this page.   Steps on how to do this are in Generating HAR files and analyzing web requests.  Personally, I like to use Chrome to create these.

I have seen some instances that find they start having specific page requests generate an HTTP 400 error on loading pages like the queues.  In the cases I have seen this the common thread has been that Jira is using a reverse proxy, and that reverse proxy is on a Windows machine.  I can't know for sure if this is the problem you are having yet, but if you do see 400 errors in that HAR file, then I would recommend checking out this bug:  https://jira.atlassian.com/browse/JSDSERVER-5667

That bug ticket is derived from this one: https://jira.atlassian.com/browse/JRASERVER-64917  Where we saw this problem started to happen for Jira environments upgrading to 7.3.x or higher that were also using a Windows reverse proxy.

From that ticket there is more explanation of the cause and a workaround:

Cause

Due to the URL length increase, we are reaching the Windows Path Limit of 260 characters. This not the IIS URL limit. More details here:

Workaround

From the above articles, it is possible to modify the Windows Registry and increase the UrlSegmentMaxLength value to handle more characters:

  1. Backup the Registry
  2. With Regedit, browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\HTTP\Parameters
  3. Find the value for UrlSegmentMaxLength (or if it doesn't exist add a DWORD value), and change it to 00001000 (this is the hex for 4096)

Powershell alternative:

Set-ItemProperty -Path HKLM:\System\CurrentControlSet\Services\HTTP\Parameters -Name UrlSegmentMaxLength -Value 4096

After using either method to adjust the registry (Regedit or Powershell), you must restart Windows for the changes to take effect. This will necessitate downtime, please plan a maintenance window accordingly.

If you are not using a Windows proxy, then you can probably ignore that bug ticket and workaround.  But instead I still think it is important to focus on the HAR file, if that does not show any errors, then the next steps would likely be to create a support zip and in turn I can open a support request on your behalf so we can investigate this further.

Please let me know the results.

Andy

Sverrir Tynes _Origo_ March 7, 2018

Thanks Andy,

I have passed this on to the System admin and I will confirm the result.  I have these error in my HAR file so I guess this is the reason for my experience in the queses.

I´ll post the results when our investigation is completed.

Sverrir Tynes

Sverrir Tynes _Origo_ March 7, 2018

The suggested workaround worked and our problem is solved.

Thanks for a great support

Andy Heinzer
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
March 7, 2018

  Awesome, glad to hear that helped.

yey.jpg

Like # people like this

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events