Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Issue with Organizations / Service Desk Organisations

Hi,

I need a way searching for JIRA items where the Organizations AND Service Desk Organisation fields are EMPTY / NULL / BLANK - however you want to put it.

I'm sure that the following JQL used to work but it no longer brings back any information.

project = "ISSCC" AND labels in (ISSUE, BUG) AND created >= 2018-01-01 AND "Service Desk Organisation" IS EMPTY

If I run "Service Desk Organisation" IS EMPTY on it's own I do get results just not when combined with other filters. This is no good for me.

I am using JIRA v7.13.1

I have never however, been able to figure out how to search for Organizations that have nothing entered.

When adding this in JIRA all I get are the following four options:

=

!=

not in

in

See attached. Default options.JPGUsing IS.JPG

Any advice would be gratefully received.

Thanks,

Matt Underwood.

 

2 answers

3 votes
Jack Community Leader May 02, 2019

Try Organization = empty. I was surprised it worked for me TBH as I would have expected the proper syntax to be “is”

Wow Jack, I've spent the last two years wondering why Organizations is EMPTY didn't work.  But Organizations = EMPTY does!  That is not proper JQL but it works.

Jack Community Leader May 02, 2019

bizarre right! i think i will check JAC and open one if not there. a bit of a nit but geez. :-(

Many, many thanks Jack - really grateful for your help with that and good to see that the solution has helped Susan too!

Now, because I want the moon on a stick(!) can you also help with the "Service Desk Organisation" issue I also have?

I have a filter with a few simple bits of JQL:

project = "BLAH" AND created >= 2018-01-01

I have then created a Rich filter and one of the static filters is:

"Service Desk Organisation" is EMPTY

When I run this through the Rich Filter Controller gadget in a dashboard I get no results.

When I run the same JQL separately I do get results - 6,753 of them.

 

With results.JPG

When I add in further JQL to the above query it also returns 0 results. Unfortunately I know there are plenty of Critical issues in our JIRA project!

No results.JPG

Once again any help would be greatly appreciated.

Many thanks,

Matt.

Hi Matt,

JQL should be "Organizations" = EMPTY

Try that

Susan

0 votes

@Jack , found one suggestion for Server:

https://jira.atlassian.com/browse/JSDSERVER-5289

Jack Community Leader May 02, 2019

thanks. i open a support ticket as i didn't find anything for cloud. i will update the request w/ that info as they may wish to simply extend that for cloud.

Jack Community Leader May 02, 2019

and now there is a cloud variant - JSDCLOUD-8107

And Atlassian linked them super quick!!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Desk

The Complete Guide to Atlassian for ITSM

Hi Atlassian Community! This is Teresa from the Atlassian team. My colleague Paul Buffington @Buff and I are excited to share a brand new ITSM resource we’ve created – "The Complete Guide to At...

2,174 views 15 22
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you