File name cannot contain the character '\'

dear,

i need help with this , im using JIRA service desk and when ever im trying to attache file im getting this message "File name cannot contain the character '\'". but there is no '\' in the file name, how to solve this?

3 answers

1 accepted

2 votes
Accepted answer

This is a known problem for service desk. There is a fix coming for those that cannot perform the workaround in the linked JIRA issue.

https://jira.atlassian.com/browse/JSD-153

0 votes

I think we need a bit more debugging information. What OS are you on, what is the browser, and can you tell us exactly how you are filling in the attachment field on the screen? (i.e. pasting a path and name, browsing, typing, etc). Is it possible to show exactly what the field contains just before you click attach?

Also, can you read the log file to see if that is throwing any warnings?

I think its IE problem, because I just tried on chrome and its working fine. I restore the IE settings and disable all the adds-on then restart but it’s still the same. Most of our users are using the IE for browsing. Could you please help me? Because I’m searching since morning for a solution but I did not find anything.

Does this happen when you attach a file to any other website? (or Atlassian's support JIRA)

If not, then IE isn't the culprit. I suspect you might have mistakenly put an additional '\' when configuring JIRA home. (not 100% sure)

That's an excellent test - try attaching a file to another Jira that is working ok.

i tried to attache file from JIRA its working ok on IE, but if i will do it on service desk portal using IE it gives me this error,

i tried to attach on another PC using IE it gave me the same error , then i tried on 3rd PC it worked fine.

if its up to me I will remove IE from all our PC's but cannot do that.

Ok, useful tests, but can you tell us exactly what string ends up as the path to the file? Copy it before clicking attach and paste it in here?

this is the path.

C:\Users\amjad.a\Desktop\my ID

i think if there is a problem with the path i will have problem also in chrome, but this only with IE.

I am able to replicate this in IE. The workaround works for now, but this is pretty disruptive on a required field with a few hundred users...

i tried to attache file from JIRA its working ok on IE, but if i will do it on service desk portal using IE it gives me this error,

i tried to attach on another PC using IE it gave me the same error , then i tried on 3rd PC it worked fine.

if its up to me I will remove IE from all our PC's but cannot do that.

Suggest an answer

Log in or Sign up to answer
Community showcase
Asked Thursday in Jira Service Desk

Looking for teams who switched from email to Jira Service Desk

The Jira Service Desk marketing team is working on a guide to help new Atlassian customers switch from email to JSD and we'd love to hear from you! Please share: - What made you realize that i...

138 views 1 4
View question

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you