Custom field (type: User Picker (single user)) doesn't allow for searching when logged in as a regular user

I have created a custom field of the type User Picker (single user). When I create a new issue with this field in the issue creation screen, I get the option to search for users awhen logged in as admin. When I log in as user I just get a text edit field, which makes it a lot harder to enter the correct user as I need to know the exact login name, instead of the real name.

The browser used as admin and as user is Chrome 21.0.1180.83. I don't see any error messages in the console.

Anyone got an idea how to enable the search option in this custom field for our regular users?

2 answers

1 accepted

2 votes

I suspect your users do not have "browse users" permission.

Go into Admin -> Global permissions and look for the browse users permission - you probably need to add "jira users" to it.

Thanks, that did the trick!

Hi Guys, I've got the same problem.. is there any solution for this?

Suggest an answer

Log in or Join to answer
Community showcase
Teodora [Botron]
Published Thursday in Marketplace Apps

Jira Inferno: The Nine Circles of Jira Administration Hell

If you spend enough time as a Jira admin - whether you are managing a single, mid-sized instance, a large enterprise one or juggling multiple instances at once - you will eventually find yourself in ...

443 views 1 15
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot