Custom Event is firing but no e-mail received.

Dear all,

This is to notify the agents that an issue awaiting approval has been approved.

I have trying to find a solution to this problem for quite a long time but I cannot get this work.  I have created a Custom Event (added the recipients), linked the Custom Event to the Default Notification Scheme (this is the only one I'm using), added a post transition function linked it to the Custom Event.  After all this I have used the notification helper and got the below result.  For me everything is working fine but I'm not receiving an email upon this transition.

I also disabled the do not notify changes made by myself in my profile.

Help is greatly appreciated since I need to put Jira helpdesk in production very soon.

Capture.PNG

 

1 answer

1 accepted

1 vote
Susan Hauth Community Champion Jan 10, 2018

Hi Ronald,

Who are the recipients for notification of the approval?  If they are not users in the actual Jira project they won't get notification. 

Cheers,

Susan

Hi Susan,

 

The recipients are the agents themselves so i guess they are obviously users of the project. The reason i want this to work is that i want the agents to be notified by email when an issue has been approved so they can act immediately. This will avoid the agents having to login to check if the issue has been approved.  Note that. Issue created and issue closed notifications are working as intended.

Susan Hauth Community Champion Jan 10, 2018

Hi,

I'm a bit stumped.  The picture looks like it's working.  Wondering if your workflow post event is not working or set up correctly?  Do you have a picture of the workflow config. 

Hi Susan, Below are the pictures for my configuration.  I am using the already pre-configured Service Request Fulfilment with Approvals workflow and the Defualt Notification Scheme.

2.PNG3.PNG4.PNG

 

Susan Hauth Community Champion Jan 11, 2018

@Nic, Do you think you could take a look.  I"m stumped...

Jack Brickey Community Champion Jan 11, 2018

correcting the @mention here for @Nic Brough [Adaptavist] to ensure he sees the request.

Hi Susan,

I do not know if I have solved the issue, but I now changed the approver to be a different user (a third person) since before the approver was an agent. Now I changed it to be a customer and when the status changes from 'Waiting for approval' to 'waiting for support' I am recieving this email.  However I'm not sure if this generated from the system update event or the issue approved custom event I have created.  How can I check the event that send this e-mail?

1.PNG

Jack Brickey Community Champion Jan 11, 2018

to test where it is coming from disable your post function and see. I'm suspecting it is the standard system event.

Previously was the approver the same person that was to receive the notification and now that is not the case. It sure seems like it would be related to 'self-notification' issue even though I see you covered your basis there.

Suggest an answer

Log in or Join to answer
Community showcase
Emilee Spencer
Published yesterday in Marketplace Apps

Marketplace Spotlight: DeepAffects

Hello Atlassian Community! My name is Emilee, and I’m a Product Marketing Manager for the Marketplace team. Starting with this post, I'm kicking off a monthly series of Spotlights to highlight Ma...

30 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot