Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Cannot my request on service desk portal

Hi all,

On the customer portal, I cannot see my request. I'm a service desk admin and agent. This happens also to other regular users. When I click on "my request" it's loading for ever and some users reported an error message:

<status>
<status-code>500</status-code>
<message>key not found: 420</message>
<stack-trace>
java.util.NoSuchElementException:

Service desk self-hosted and version 4.0.0. I upgraded from 3.8.1 hopping this issue will be solved as it was discover at the same time the upgrade was planned.

Any ideas? I have read this could be for people who are not consuming a license but it is not my case.

Thanks!

1 answer

0 votes
Taranjeet Singh Community Leader May 03, 2019

@PaulaA Please check this KB article and see if you are experiencing the same issue and try if the resolution mentioned here resolves your issue: https://confluence.atlassian.com/jirakb/jira-service-desk-shows-500-error-on-requests-page-931234256.html

Taranjeet Singh Community Leader May 06, 2019

@PaulaA Did the above answer help resolving your issue ?

Hi @Taranjeet Singh 

Thank you but this didn't work. I have a test system with old data and there works. I run the query in both prod and test and the result is the same, I have two request types with no fields.

To avoid some other issues, we hide from the portal some request types so people can assign later on Jira and then agents can edit the issues when needed. Could this cause the issue? It's the only difference that I can think of.

Thanks

Taranjeet Singh Community Leader May 07, 2019

@PaulaA I would still suggest to follow the resolution suggested in the above KB article in your Production instance, to see if it resolves the issue.

 

Regarding the request types that you are hiding from portal and are only available for agents, I don't think those could be the cause of this issue. 

hi @Taranjeet Singh 

I cannot edit the fields following the documentation. I'm on the request type menu, edit field shows an error: Field does not belong to the Request Type.

https://confluence.atlassian.com/get-started-with-jira-service-desk/create-service-desk-request-types-917968307.html

Sorry, i cannot paste a screenshot

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Asked in Jira Service Desk

Calling all Mindville Insight users, we need your help! (there might be swag involved)

Hello Insight users,  As part of our (Mindville's) acquisition by Atlassian, our training team is looking to build some new Insight training materials and we want to hear from you!  ...

296 views 4 6
View question

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you