Cannot Install JIRA Service Desk Edited

I tried to install service desk using the .exe and it does not show up, I tried using the try for free link on the applications page and that gives an error to check the logs, but does not specify where the logs are.  When I installed using the .exe it defaulted to upgrade my current installation, which was pointing to my Jira Software installation, that appeared to have installed but opened up to only display Jira Software and no sign of Service desk.  Do I need to install this thing from scratch and if it never uninstalled fully how do I clean it up?

I just went to double check some items, this is a windows 64 bit install.  I had Jira Software and Confluence running just fine.  I had Service Desk installed a while ago but something went whacky with it, hoping a new install after almost a year would fix it.

I just looked at my installed programs and Confluence is there, but Software has now been replaced with Jira Service desk in the windows programs installed.  When I am in Jira though, and do a new project I still only have Business and Software as options.  This is weird.

 

2 answers

0 vote

Service Desk and Software are "applications" that are installed on top of Jira Core.

If you have no Jira install, then using a .exe file to get started is the right thing.  If you already have Jira running, forget downloads, go to Admin -> Manage applications, and install from there.

0 vote

The exe installer is really only used if you don't have Jira installed yet at all. If you have an existing Jira Core/ Jira Software installation, then you can more easily add Service Desk to that install without using the exe installer.

I would recommend following the KB How to install JIRA Software / JIRA Service Desk into an existing JIRA instance.

Neither are working, when I try to install Service Desk using the Try it for Free button it ends up with this message.  An unexpected error occurred. Refer to the logs for more information.

 

I looked at logs, not sure if they are the right ones but I could not see any message that stands out as what the problem would be.

 

Background, I've had Jira Software and Service Desk running a long time ago.  I uninstalled Service Desk hoping to resolve an issue but I have never since been able to reinstall it after that.  I always got that error message above.

Oh, that could explain it.   If you were running an older Jira Service desk in the past, (any version before 3.0.0) and then you removed it, and then upgraded Jira beyond 7.1.x, there is a serious problem where the newer versions of Jira/Service Desk cannot upgrade these older versions.

What version of Jira are you running right now?

This is a well known problem starting with the Jira 7.2.x and JSD 3.2.x versions, but also effects higher versions of Jira.  There is a comprehensive guide that explains the problem and ways to get around this in the KB After upgrading to JIRA Service Desk 3.2.x or greater, Service Desk project's navigation bar shows "Unable to render element due to an error".

The documented way to resolve this actually has you downgrading Jira to a version such as 7.1.9.  On this version you can then install a Service Desk 3.1.x version.  That version can then upgrade your existing Service Desk data (provided you activate a license for that product, an eval license works and you can get it from https://my.atlassian.com , and then the plugin can start up on restart of Jira).

That is the way we would recommend handling this in support.  It's not ideal, but there really is not a supported way to completely remove that existing Service Desk data from the database.   There is a feature request to allow that, so that in cases like yours, if you do not want that old JSD data and just want to dump it all to try JSD again, in theory you could do so.

That feature request is https://jira.atlassian.com/browse/JSDSERVER-4732

While Atlassian has not officially implemented this, there are public customer comments on that page that indicate there are certain tables that can be dropped from the database IF YOU DO NOT WANT THE OLD SERVICE DESK DATA.   But I would recommend that you create a backup of your database before you try this, it's possible this could help you get past this problem without having to deal with a downgrade, but this kind of data manipulation to your database is not directly supported and does have the potential to blow up a Jira instance.   So if you go this route be sure to create a backup of your database, and test this out on a staging server first.

I am running Jira Core 7.6.2 and Jira Software 7.6.2 and also the latest release of Confluence.

The database table removal still did not help the issue with the error during the application page install using the free trial button.  But what is interesting is that I was looking for the logs like it said to do but I can't find them.  I ran across System Support/System Info.  and towards the bottom under User installed Add-ons it shows Jira Service Desk 3.9.2-REL-0010 Enabled, then Service Desk Application 3.9.2 Disabled with data center compatible True.  others are same version info Project Plugin and Public REST API Plugin.  not sure if that helps at all, seems like its installed, just something dumb is blocking it.  Probably me.

Brain,

The logs for Jira are going to be in the $JIRAHOME/log/ folder and possibly the $JIRAINSTALL/logs/ folder.   These might be helpful in understanding why service desk is not working.

Since it sounds like you might have already tried the database route, you might try this again, but this time try these steps:

  1. uninstall Jira Service Desk
  2. then shutdown Jira
  3. create a backup of your Jira database
  4. then try the steps to remove those specific AO_ tables that pertain to Service Desk from that database
  5. Then start Jira again
  6. See if you can reinstall Service Desk once more

If you still cannot seem to get Service Desk to work, then I would be interested to see what kind of error being thrown in the logs.  It's possible sometimes that a plugin can get disabled in the database.  If this happens there tends to be a flag field on that plugin in the pluginstate table.   It might help just to see what entries exist in that table with the SQL command:

select * from pluginstate;

Andy

Since I don't have much invested in Software or Core, do you think it may be easier to just do a wipe and fresh install?  If so Is there a step by step on how to completely wipe Jira out and start fresh?

If you don't need the Jira data you currently have, then you could just shut down Jira, blow away the $JIRAHOME/dbconfig.xml file (delete works, but for safety sake maybe just move that file out of that directory), and then when you start Jira again, it will launch the setup wizard once more.

Granted you still need to create a brand new database in this kind of setup, and to do that, you will need to follow the steps of one of the database guides on Connecting Jira to a database.   But this is one way you can start over with Jira, without having to create a new installation.  

Just note that this kind of change eliminates all Jira issues and configurations.  It's like starting over from scratch again.

Suggest an answer

Log in or Join to answer
Community showcase
Teodora [Botron]
Published Feb 15, 2018 in Marketplace Apps

Jira Inferno: The Nine Circles of Jira Administration Hell

If you spend enough time as a Jira admin - whether you are managing a single, mid-sized instance, a large enterprise one or juggling multiple instances at once - you will eventually find yourself in ...

1,208 views 6 19
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot