Can't create new automation rules in JIRA Service Desk

Hello,

I have created 3 rules previously through our automation in JIRA Service Desk.  I was trying to create a new rule and I noticed by selecting the Rule type and clicking next, nothing happens.  I can go back and edit the three rules that are currently running, but I cannot create any new rules.

We are using JIRA Service Desk 3.2.7 currently.

Thanks,

Art G.

5 answers

I also getting the very same error. I still can edit existing rule but can't create new rule.

0 vote
Paulo Hennig Atlassian Team Nov 23, 2017

Hi, Art.
Since nothing is happening when you're proceeding with such a task, would you mind to open the developer tools of your web browser, ensure to select "network" and double check if you have an additional message when replicating this behavior? I'm asking for this just to ensure that we can try to isolate the point of failure of this behavior.

A nice option to try as well would be to create a fresh Service Desk project and see if the same behavior happens, so we can see if we can isolate this issue on the project itself or somewhere else.

Same here with Service Desk in JIRA v7.7.0.

Selecting "Automation" in the Project settings, "Add your first automation rule", 7 rules + Custom rule are selectable. But a click on "next" leads to a blank working area.

Would sure be great to have a solution.

 

Thanks

Jan

Sujit Nair I'm New Here Wednesday

Does Atlassian support have a fix for this?

Seems like this issue is impacting a lot of customers.

Thanks.

We have the same problem with JSD 3.10.2 on JIRA Software 7.7.2.

Any suggestions? Automation is one of the most powerful features in JIRA Service Desk and it is not good experience that one can´t create new rules.

0 vote
Dave Norton Atlassian Team Wednesday

Hi folks! I discussed this problem with @Sujit Nair (who commented in this discussion) and we quickly uncovered this is a known problem when using IIS as your reverse proxy.

If you're using a IIS based reverse proxy, check out the Windows Event Logs - they should show an "illegal character" present in the URL. 

This KB article has the steps to resolve the problem - changing the site's web.config file should be enough to get it resolved.

It's also very possible you might be running into a different, yet similar bug which also produces error 400s on other pages - so if the KB article doesn't sort you out; it might be worth checking out if you're being affected by JRASERVER-64917 as well :)

Let us know how you go!

Cheers,
Dave
Senior Support Engineer (Sydney)

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Bridget Sauer
Published Mar 09, 2018 in Jira Service Desk

E.L. Fridge's take on education, Jira Service Desk, and creative Jira use cases

...word of mouth, so by 2016, we were working with several other entities on campus to implement Jira Service Desk . The Atlassian motto of “for every team” has really come true for us in this case. We...

1,231 views 2 14
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you