Can't create a Service Desk Project

Hi

Whenever I try to create a Service Desk Project, it fails with the following error-message: "Hmm... we couldn't create your project due to an unknown error. Try refreshing the page to start again."

The atlassian-jira.log showes following error: 

/rest/project-templates/1.0/templates [c.a.p.r.c.error.jersey.ThrowableExceptionMapper] Uncaught exceptio$
java.lang.RuntimeException: An error occurred while notifying that a project was created
        at com.atlassian.jira.bc.project.DefaultProjectService.notifyHandlersOfProjectCreated(DefaultProjectService.java:397)
        at com.atlassian.jira.bc.project.DefaultProjectService.createProjectInternal(DefaultProjectService.java:379)
        at com.atlassian.jira.bc.project.DefaultProjectService.createProject(DefaultProjectService.java:349)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)

The suggested resolutions didn't help much. Did someone here experience something similiard to this with Service Desk? 

 

Thanks

 

 

1 answer

1 accepted

0 vote

Hi Stefan,

What solutions have you tried at this point and does this happen on all projects or only Service Desk projects?

There is an article titled Couldn't create your project due to an unknown error. Try refreshing the page to start again that may be of assistance if you have not seen it already.  The article describes the cause as follows:

Due to there are NPE on the permission scheme, where a reference on the permission scheme is missing. This can be confirmed with the SQL query:

select * from schemepermissions where perm_type = 'user' and (perm_parameter in (select user_key from app_user where lower_user_name not in (select lower_user_name from cwd_user)) or perm_parameter not in (select user_key from app_user));

If you do see missing permissions please follow the steps in Couldn't create your project due to an unknown error. Try refreshing the page to start again.

If that does not work, the next step would be to turn up the logging for Service Desk and provide the debug logs.

Cheers,

Branden

Hi Branden thanks for the answer, basically i tried that: https://confluence.atlassian.com/jirakb/hmm-we-couldn-t-create-your-project-due-to-an-unknown-error-818580338.html

 

Which didn't help in my case. I can try and run this sql query but i allready granted the suggested rights and permissions to the users on the server, as suggested by Atlassian. The funny thing is, I can create Business and Software-Projects without any errors. Its only an issue with Service Desk. 

Hurray! The problem got solved. We changed the language to EN-US. 

Hi Stefan,

I'm very happy to hear that.  I have seen some instances where certain language packs will cause issues, e.g. JSDSERVER-4170.  If that does indeed match your language you can vote on that issue to add impact.

If that is not the language, let me know what language it is so I can see if there is a current bug for it and if not I can make one that the Community can vote on.

Cheers,

Branden

Hi Branden,
I have the same problem for Czech language  -  it's impossible to create the Service Desk Project. there is a workaround changed the language to EN-US.

Hi Roman,

Thank you for the update.  I have created JSDSERVER-5545 for this particular bug with the Czech language.  I tested in the Cloud version and did not run into this issue so I believe it's isolated to the Server version, at least for the current release. 

At this point, please vote on the issue and let me know what version of Service Desk you're using so I can add that to the affected version if you are not on the latest SD.

Cheers,

Branden

Hi Branden,

I'm using the latest version  3.9, but the problem is older I'm not sure when the problem appeared......

 

Best Regards,

Hi All!
I confirm this bug on Jira Service Desk 3.8.1 in RU localization.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Bridget Sauer
Published Mar 09, 2018 in Jira Service Desk

E.L. Fridge's take on education, Jira Service Desk, and creative Jira use cases

...word of mouth, so by 2016, we were working with several other entities on campus to implement Jira Service Desk . The Atlassian motto of “for every team” has really come true for us in this case. We...

970 views 2 14
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you