It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Automation for Jira clone issue with custom fields Edited

I'm trying to crate a rule where the issue is cloned to another project.

Both projects has the same mandatory 2 custom fields.

By default, the Clone Issue does not clone custom fields with its values and therefore fails, so I'm wondering could someone help me here.

image.png

I've added JSONView and the fields on original task are below:

fields{

customfield_10802: "ABC",

customfield_10807: "Distribution",

names: {

customfield_10802: "System",

customfield_10807: "Module",

 

The question is, how can I clone the issue with both customfields and their values?

3 answers

1 accepted

0 votes
Answer accepted

I was able to fix this by adding following under More Options:

 

{
"fields":
{
"customfield_10802":"{{issue.customfield_10802}}",
"customfield_10807":"{{issue.customfield_10807}}"

}
}

 

That's it.

Hi Valdis,

 

put all custom fields you need to copy in a view screen, the fields need be on a screen of the destination issue.  

Hi Lucas,
I'm not sure I got what you mean.

Both fields are on create issue screen and required while creating the issue in source and destination project.

1 vote
Scott Harwood Community Leader Jun 09, 2019

Hi Valdis,

This should work without you having to supply any additional configuration. However you will need to have the destination project in the "Restrict to projects" field in the rule details. 

Cheers,

Scott.

Nah, still fails. :(

I added both projects in "Restrict to projects"

Source is Service Desk project, other is Jira Software project..

 

Clone issue

Error creating issueSystem is required. (customfield_10802), Module is required. (customfield_10807)

It even fails to clone the the issue in the same project:

 

image.png

@Scott Harwood  response from the support was:

There are some limitations with our cloning functionality, but I believe copying custom fields should work.

But only way I did fix it, was adding JSON Script to set the values.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Jira Service Desk

[ Survey ] What does the future of ITSM look like? Take our survey today!

Hi all! We’re interested in learning more about your ITSM practices - what’s the current state of your ITSM practices? What are your aspirations for your IT team in the future? Which ITSM trends ar...

232 views 1 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you