It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unable to load Portfolio Plan (Source map/404 error) for 1 plan

A few days ago, the Product Manager was able to see a  Portfolio Plan and prioritize the stories in it.  Today, when they go to open the plan, it hangs.  Other plans seem to load ok, but there is something funky with this particular plan and I can't navigate to Configuration on it to see if it's a problem with the query or the filter or anything.

If I look at the Console on the page, it complains about a Source map error (failed status 404)

Browser: Firefox

Portfolio Plan Problem.png

4 answers

0 votes


Thanks for the details and this is odd and defiantly looks like you're hitting some buggy behavior on that plan.  I have not seen that error before I have done a bit of searching and I'm not finding anything specific on that error so we will need to narrow this down with some troubleshooting.

First off, you noted that you are seeing this on Firefox, is this occuring on alternate browser types as well or is is specific to Firefox only?  Also Just to rule out anything that might be locally occuring in the browser check out our "Browser Troubleshooting Guide" for a few additional items to check.

You also noted not being able to navigate to the plan settings to check the issue sources for problems in the filters, can you try using the Direct URL to get to the settings, with this format to take a look at what projects are bing associated via the connected board filters:


If you are able to get to the setting with the direct URL check the issue sources for the plan and let me know the full filters used by any of the linked boards.

If you cannot get the issue sources from the UI on the front end the data is stored in the database in the table "AO_D9132D_ISSUE_SOURCE", from your screenshot the plan ID is 50 so you could use the following Query to get the issue source data (Noting format is for PSQL so adjust accordingly for your db type):


Look at the "SOURCE_VALUE" column and this query will give you rapid view id for any linked boards and the project ID for any linked projects.  To get to the board associated with the noted rapid view ID go to BASE_URL/secure/RapidBoard.jspa?rapidView=Insert_Rapid_View_ID_here, and again pull the filters so we can take a look to see if anything is odd in the filters.

Also can you check the logging for any errors triggered when you load the plan that could help narrow this down further.



I can confirm that this is also happening to a client of mine also.


I have tried to look at the logs by ssh into the box, but nothing generated and no issues shown. Is there a step by step process to resolve this?

What is this issue? I've been using Chrome and Safari and they both did this.

Kind Regards


Hi @Jeffrey_Agyei ,

Thank you for adding in the additional input here and while I'm not happy to hear you're seeing this too, its good to know that this is impacting multiple people for narrowing down the causal factor and adding more evidence to this being a clear BUG, we just need to figure out how to reproduce it now.  

First I just want to confirm that you are indeed seeing the same "Source map" error with the 404 in the screenshot with matching or similar source map URL and  Resource URL's, please not any differences you are seeing, and include a screenshot if possible.

Next let's try to isolate some of the variables, What Jira version and portfolio version is currently in use in your instance?

I've been playing around with this a bit in my test instances and I cannot trigger similar behavior with a few different stets of test data populated on a Jira 8.2.3 with Portfolio 3.6.0, so it has to be something either in the data and the data mappings triggering this, or a bug in the specific Portfol/Jira version or conflicting apps. 

Starting at the filters as noted above would be the best bet, and if you can collect the filters and projects used on the boards tied to the plan I can try aligning my test data with similar issue sources to get my data inline for reproduction steps.

Also is you're looking at the DB can you send through the results of the queries.

As noted initially it was difficult locating the issue sources to see what board filters were tied to the plan, I listed a few queries previously and a method to get the filters from the UI using the rapid vew id and a URL hack but an additional query that can be used here to just pull the filters using the rapid view id directly from the db would be:

select rv."NAME" as boardname, sr.filtername, sr.reqcontent from "AO_60DB71_RAPIDVIEW" rv, SEARCHREQUEST sr, WHERE rv."SAVED_FILTER_ID" = AND rv."ID" in (Insert a comma separated list of the rapid view  ID's from previous query HERE);

Also as you noted not seeing any explicit errors in the logging when you were looking, so enabling debug logging would be the next step to get a super detailed view on what is occuring here when that page is being loaded data-wise, noting this will populate a tone of output in the logs when enabled, but add the following packages to the debug level under logging and profiling to get portfolio debug enabled:


Let me know if debug logging identifies anything odd in the load orders or hangs in any way, and i recomend reseting the packages to the level error or warn to not overload the log files once you load the page. 


Also @Jeffrey_Agyei And @cchampoux ,

One more note on this is that the source map error that is really the only factor we have to go on so far is looking more like a UI error rather than anything to do with Portfolio, and a suggestion that if you do not find any other explicit error's when the timeout occurs even with debug on, the best approach to troubleshoot this further will be to get us a HAR file on the page load so we can see the full start to finish browser side load out and whats happening where its hitting the wait action in the browser, in conjunction with the server logs in the form of a support zip

(!) However, please note:  these files will include detailed info about your instance that should not be uploaded to the community forum and we will need to get you in touch with our support team via to review this in our secure portal so we can look into this in more detail.

But first let me know what you find, and if you do not find anything and additional details are needed I will get a support request going on your behalf so we can dig into this further.


Hi @Earl McCutcheon 

The issue is, is the browser just freezes. This is something that occurs in all of the users, trying to access this.

Their current Jira Server is; v7.13.5 and their Portfolio for Jira version is 3.6.0.

Right now, i'm trying to record for the HAR files, but again they are not recording this, as the page has frozen, just a blank screen.

It's trying to collect the data but yet again, it's not moving.

Any other suggestions?


Hi Jeffrey,

Thanks for the updated info, And using the same versions of jira and portfolio I am still not able to replicate the error, so this is either an environment issue or a data conflict, so at this point lets get you a Support request created so we can dig in to this error a bit more and figure out where the page is hanging up.

With the HAR file creation everything up to the point where the browser is hanging, and what UI elements are loading when the hangup occurs is what we what we want to see so we can look at those packages and attempt to replicate the behavior.

But as you noted the browser is hanging and your having difficulties getting the HAR file because the page load never completes, what you can do is; go to the network tab and select preserve log and start recording for the HAR, load the page to the point the browser hangs, then let it sit for a moment incase anything starts progressing and something else is recorded (30 seconds should be plenty of time) then manually deselect the REC icon to stop the recording and cap out the HAR file properly so you can then save the output up to the point the error is occuring.

Upload the results of the HAR file and a to the following Support request I created for you so we can take a closer look:


Hi @Earl McCutcheon  ! Im having the same issue with one of my plans. Its not in all plans but just this one. Is there any update on this issue?


Thanks in advance

Hi @Nicolas_Gonzalez ,

Thanks for reaching out, and Internally we still have not been able to reproduce this behavior and looking into this the Support request we created to look into this further, mentioned earlier in the thread, it was put into a long term frozen status while the original reporter  had to follow up with additional duties before looking into the issue, noting he would circle back at a later date, and no progress was made on the investigation and we are currently still waiting on follow ups to start investigating the behavior.

We are still really invested in trying to track this one down but we need to be able to replicate the behavior and look through logging as the next steps because teh causal factor is still unknown. 

Also just to get some clarification on the behavior you are seeing so we can isolate any differences that could help track this down:

  • Are you just seeing the plan hang or are you seeing it hang + the matching javascript output in the development tools browser console? 
  • Also What troubleshooting steps have you tried up to this point? 
    • i.e. have you run through the  "Browser Troubleshooting Guide"  and looked at the DB queries I mentioned earlier in this thread, and have you noticed any deviation in the behavior or error outputs mentioned earlier on?
  • What versions of Jira and portfolio are you running?

If there is not anything standing out as different to test against we would be at the same point of needing additional info to make any progress, so if this is the case let me know and we would like to get you in contact with our support team to dig a bit further into the jira instance to look at this behavior so we can try to isolate what is causing this buggy behavior.


Did this get resolved?

I'm currently having the same problem using Google Chrome as my browser.  At first I thought it was a "trying to connect to too many projects" error but I have verified my queries are within the necessary limits.  

Here is what's going on:

When I attempt to load my Portfolio Plan the page begins to load and the column where the issues should be displayed has blank with color rolling rectangles displayed.  When I hover over the rectangles a message popups saying, "Loading Issues...".  This occurs for 5+ minutes then the rectangles disappear and the columns where issues should appear are empty.

Why is this happening and how do I fix it? 

Suggest an answer

Log in or Sign up to answer

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you