It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Receiving "Something went wrong" went having JIRA send me the code during 2-factor setup

I am trying to set up 2-factor authentication without adding an app to my phone.  When enter my phone number and click on "Text me the code" I get "Something went wrong".  


I did an F12 in the browser and see "Access to XMLHttpRequest at '' from origin '' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource."


I've tried with Internet Explorer, Chrome and Firefox.  All give me the same error.  How do I resolve this?

1 answer

0 votes

Hello Tony,

Thanks for reaching out, and during the timeframe you submitted this question there was an outage related to the Atlassian Identity login management system that prevent users with SSO and Dual factor authentication methods to become locked out of the system temporarily.

The issue has since been fixed, and we are monitoring the status and post incident review here:

Can you try the authentication again and let us know if it is working for you now or if you are still seeing the error?


Unfortunately, I get the same error.  Just to be clear, this is during the setup of two-factor, not during the login.

Hi Tony,

Thanks for the follow up, and CORS errors are not that common in JIra cloud outside API calls, and I just want to verify that your following the below set up process, as I was testing this one out and could not trigger the error:

Next, too narrow this down a bit further a CORS error is occuring on the connection to the external system as a web protocol to verify the origin of the returning connection to tell a browser to let a web application running at one domain (the origin) have permission to access selected resources from a  different domain, and usually is going to be a network issue or a browser issue causing the hiccup.  

First I would recomend opening the development console on your browser and going to the network tab marking the option "Disable cache" and refreshing the page to see if this can bypass the error.  Then Try incognito window as well as the other steps listed in our "Browser Troubleshooting Guide" noting the step to bypass a proxy for cloud would be accessing from another network to bypass the local proxy, not the server side proxy.

Next you can also try launching your browser with the web security disabled (EXE for chrome can be seen here), to fully rule out any browser security settings as the cause.  With a note not to continue running with this disabled as it will open you up to vulnerabilities long term.

If the error is still occuring after these checks it is going to be something in the network settings filtering out the origin headers triggering the CORS error, and this would circle back to the browser troubleshooting guide noting testing the connection on an alternate network such as tethered to your phone with any VPN disabled rather than the work network to get outside any filtering that may be occuring on the firewall.


Suggest an answer

Log in or Sign up to answer

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you