starting a Jira core 4.0 after a linux server restart Edited

Hello,

I'm a DB Developer that inherited a jira system on a Linux CentOS VM machine, we had power failure and all the servers restarted, after restart jira is not coming up!

there's no such file as Jira-Start.sh ! I searched all over.

any idea what's going on? any help is appreciated please.

 

thanks

Jason

 

1 answer

1 vote

The concept of "core" only came in with JIRA 7.  You say you're on JIRA 4.

However, whatever version you are on, have a look in <jira installation>/bin for the startup files, and <jira home>/logs for the reasons why it might not be starting.

Hi Nic

thanks for jumping in,  yeah not sure about the core part but we only got the Jira software , installed in /apps/jira/

I see a folder called LOGS, but it has thousands of files, I don't see a recent one by looking at the time stamp, maybe it's not even being set to start automatically?

 

I see file called : startup.sh  in the Bin Folder, running that gives the that message:

 

jira 1.PNG

searched online and created a script to point to JAVA and call the same file, but gets that error now !

 

jira 2.PNG

 

hope you can help me with that issue.

 

thanks

Jason

 

Ok, if there's nothing going into the <jira home>/logs, then the Tomcat is not getting as far as starting the application.

So, we need to look into <jira installation>/log directory for "catalina.out" and look at the end of that file to see why it's not starting.

Hi Nic,

thanks again for your answer, I see that catalinaout has only date from 2/2017, so looks like i'm not starting the services right.

jira 4.PNG

here's my script, i must be doing something wrong..

 

jira 3.PNG

execuse my Linux ignorance!

 

Not a problem.

If you go to /apps/jira/bin and run startup.sh manually, then it should either error, or try to start JIRA and write to the catalina.out file.

when I do that I get the java error, that's why I created my script

 

jira 5.PNG

Ah, sorry, I forgot, JIRA 4 doesn't have its own JRE.

The JAVA_HOME in your script is wrong, which might explain some of it.

First run

ls -l /usr/bin/java

I expect it will say something like

java -> /usr/local/java_1.6/bin/java

You need to set the JAVA_HOME to be the path to the complete java installation, the directory above /bin/java.  (So in my example, you'd need JAVA_HOME=/usr/local/java_1.6 )

Also, your script is using the wrong start-up.  The JIRA start script already calls out to catalina.   You should remove both of your lines refering to catalina from the script.

Hi Nic,

I did that, but still no luck. here's a screenshot.

 

jira 8.PNG

So what does catalina.out say now?

I changed it to /usr/java/default  and it started, but the header is blue, not red!! and also it's giving me an error.  see attached.

 

jira 9.PNG

Nic, there's no .lock file exists at all !!  any idea?  looks like we're so close...thank you for all your help..

Stop all the Atlassian applications on the machine, then check the lock file is definitely gone, then try again.

Hi Nic,

How to identify what's running? and how to stop them?

I just restarted the whole server, checked the URL nothing works, started just "Jira "and same error message came up about the lock!! although there's no .lock file!!

it's showing in the error that "usr/local/jira" is being locked,  I'm running it as Root, maybe I need to run it this Jira user??   sorry I'm asuming there's a user called "Jira" ?! by looking at the error message...

 

 

I think you need to go back to the basics, not just dive in and hope you hit the right thing.

You need to establish where jIRA is installed, where its home directory is, and what you need to run to get it to work.

Your script is doing the wrong thing, I'm not even sure how you managed to come up with it.

But to answer some of your follow up questions:

To find out what's running on a Linux system, use "ps".  I usually use "ps -ef" or "ps -aux".

No, JIRA should be run as the dedicated user for it.  If it's run as root, it's a security risk.  Once it's been run as root though, it messes up the permissions on files, which you'll need to reset.

thanks Nic, i'm trying to find a way to re-install Jira from scratch and just apply the latest backup! :)

maybe a windows one so it'd be much easier than dealing with linux !

 

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Thursday in Jira

5 ways you can make the most of Jira Software and Bitbucket Cloud

As part of the Bitbucket product team I'm always interested in better understanding what kind of impact the use of our tools have on the way you work. In a recent study we conducted of software devel...

106 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you