reindex failed with no such file or directory error

I recently upgraded JIRA from 5.2.11 to JIra 6.4.11.

At the end of the migration, everything seems to be ok.

index was successful.

Then I installed some plugins such as easy bi and rmsis.

Then it was impossible to reindex.

The errors are like this one :

2017-01-14 19:00:07,757 IssueIndexer:thread-5 WARN sat 1127x106x1 1a7ag5f 10.51.9.120 /secure/admin/IndexReIndex.jspa [atlassian.jira.index.AccumulatingResultBuilder] Indexing failed for Issue - '739804'
2017-01-14 19:00:07,757 IssueIndexer:thread-5 WARN sat 1127x106x1 1a7ag5f 10.51.9.120 /secure/admin/IndexReIndex.jspa [atlassian.jira.index.AccumulatingResultBuilder] java.io.FileNotFoundException: /data/jira/jiraatgl6/home/caches/indexes/issues/_bnbl.cfs (No such file or directory)

Then I cleared the cache, reindex again but the result is never the same, sometimes it works and sometimes not. The % is sometimes different.

I uninstalled the 2 plugins, same result whereas it worked once.

The filesystem is obviously not full.

On this server, Jira5 is still running and reindex is always ok.

Please help !

1 answer

0 vote

Check the permissions and ownership of the index directory (actually, I'd check the whole of <JIRA home> has the same owner and it's the user that runs JIRA as a service)

However, as it seems to be your add-ons rather than JIRA, I'd test that more - does it work fine before you add them consistently?  If so, then add one of them and see if it still works.  If it fails, remove it and re-test to make sure it goes away.  If it works, then add the next one and re-test.  Narrow it down to a single add-on.

Thank for your reply. The rights of the directory are good. The problem occurs at random.

I have a suspicious plugin indeed. I think that this plugin can modifiy JIRA datas by rest api because some users may send requests to this plugin during the reindexing operation.

Can we be sure that JIRA blocks any access even from plugins during reindexing operation ?

What is your point of view ?

 

It could be anything in the add-on, not just REST calls.

If you're doing a full foreground index, then all access is blocked.  If it's a background index, then no, because you'd have to lock everything out, not just REST.

You need to identify which add-on is causing the problem first.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted 9 hours ago in Confluence

Calling all marketing teams who use Confluence - we want to hear from you!

Hi Community! me again 🙂 If you’re a marketing team using Confluence, we want to hear your story! How did you start using Confluence? What are your use cases? What have been some of the benefits?...

41 views 1 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you