how to import the backup of jira core 7.0 to jira 6.4

we want to degrade the JIRA from V7.0 to V6.4,

but cann't succeed,  the feed back is blow:

Error importing data: java.lang.IllegalArgumentException: [GenericEntity.set] "parameters" is not a field of

what can I do for importing successfully?

any addon can realize this?

 

1 answer

1 vote

There is no "downgrade" route. 

There are ways you can bodge a number of minor releases to downgrade (like JIRA 6.4.3 to 6.4.1), but there's no chance of 7.x to 6.x

Your choices are to revert to the last backup you took from your 6.4 system (and lose all the data entered since) or run with your 7.x system.

This all begs the question - "Why are you trying to do a (pointless) downgrade?"

What he probably means is using the autoexport of the JIRA 7 installer to go back to JIRA 6.4. However JIRA 6.4 won't read the exported data! Fail!!

Yes, the docs do all say you can't downgrade it.

If the auto-export created by a new JIRA version before the actual upgrade takes place cannot be used to revert back, then what is it good for? Why is that considered a downgrade if the upgrade hasn't even happened yet?

No, you've not understood the question or the answer.

They have taken an export from 7 and tried to import it into a 6.4 system.  They haven't tried to revert an upgrade, they've tried to downgrade a system.  Which can't be done.

Ok, got it. However: One of our guys recently pointed a JIRA 7 installer to a JIRA 6.4 database by mistake. Needless to say it was then FUed. Trying to use the auto-export created by his JIRA 7 installer resulted in the same error message.... That's why I was making the comment.

Hard to say why that went wrong without seeing the error messages (and assuming you rebuilt the 6.4 from a clean install before trying to restore the export - downgrades don't work, you need to start clean)

It's worked fine for me on the couple of times I've wanted to test it.  But I tend to disable the export when upgrading to speed it up, I work with large datasets a lot and prefer to rely on a hard database copy for speed and reliability.

 

In fact the autoexport of the 7.0 installer contained "<ClusteredJob>" tags in entities.xml. This does not seem to exist in 6.4. After removing those, the import in 6.4 worked ok. (We also used activeobjects.xml from a previous backup of 6.4)

Suggest an answer

Log in or Join to answer
Community showcase
Emilee Spencer
Published yesterday in Marketplace Apps

Marketplace Spotlight: DeepAffects

Hello Atlassian Community! My name is Emilee, and I’m a Product Marketing Manager for the Marketplace team. Starting with this post, I'm kicking off a monthly series of Spotlights to highlight Ma...

38 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot