When marking an issue as done, the resolution that I choose is not being set.

Ok, so I have a Resolve Issue screen with "Resolution" as the only field. The transition to "Done" is set to use this screen. When a user marks an issue as Done, the screen comes up with the options: Won't fix, Done, etc...

The problem, is when I set the resolution as Won't Fix or any of the other values, "Done"  is always set as the resolution no matter which option I choose. Is there something else I need to do to get the resolution to set something else besides Done?

1 answer

1 accepted

1 vote
Accepted answer

It sounds like there is a post-function on the workflow that is setting it (post-functions happen after the screen, so it's stomping on what the users choose)

That was it! I copied the workflow and didn't notice the setting. Once I removed the post function it worked perfectly.

Hi, I have the same issue. Can you tell me where to find the post function setting please??

On the workflow transition - you'll need to go into edit mode on the workflow to see the detail.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Friday in Jira Service Desk

Looking for anyone who has switched from Zendesk to Jira Service Desk

Hi Community! The Jira Service Desk marketing team is looking for customers who have successfully switched from Zendesk to Jira Service Desk!   We’d love to hear your thoughts on the pros and ...

68 views 6 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you