Trying to Create a Test Environment

Hello,

I work for a company that's currently operating on JIRA 5.2.5, and we're looking to upgrade. We think the first step of doing this is to create a test instance of 5.2.5, point it at a duplicated version of our live database and see where we can go from there.

So, we have a VM setup, and a tunneled connection to a MSSQL server. I've since installing JIRA 5.2.5 onto this machine, but unfortunately, I've got an error when trying to load up. Essentially, it's stated that my build of 5.2.5 isn't compatible with the DB we're using in live. For ref, we're using v5.2.5#847-sha1:7fd7dd6 in live currently, but the version downloaded from https://www.atlassian.com/software/jira/download-archives seems to be different.  

Can anyone suggest a good away round this, or, alternative another way of doing things?

1 answer

0 votes

Hi Ed,

Can you provide a screenshot of the error and the version of MSSQL you are using?  The supported MSSQL versions are as follows per the Supported Platforms page for 5.2.x:

(tick) 2008 with the JTDS 1.2.4 driver
(tick) 2005 with the JTDS 1.2.4 driver

In addition, is this a clean install of 5.2.5 or a cloned instance and what errors do you see in the logs.  Please post a screenshot of the error, any relevant log messages and the provide the version of MSSQL you are using.

Cheers,

Branden

Hi Branden,

Thanks for the response. Please see the below for what I'm seeing in terms of an error message.

JIRA Error.png

It's a clean install of 5.2.5 x32. I'm only seeing the following in the logs:

2017-09-25 10:52:48,824 localhost-startStop-1 ERROR      [atlassian.jira.service.OfBizServiceConfigStore] The class 'com.atlassian.jira.service.services.auditing.AuditLogCleaningService' could not be found.  This can happen when a plugin is uninstalled or disabled
2017-09-25 10:52:48,825 localhost-startStop-1 ERROR      [atlassian.jira.service.OfBizServiceConfigStore] A NoOp Service has been returned and hence 'Audit log cleaning service' will not do anything until fixed.

I have a feeling that the server is MSSQL 2008, but will check with our database team and report back.

For reference, the MSSQL is 2012 x64.

Thanks!

Hi Ed,

I would check the target database again.  The error you're getting is stating the database is using version 64014 which is JIRA 6.4.

Make sure the version you're installing is indeed the 5.x version you had previously and retry on a supported database for that version of JIRA.

Cheers,

Branden

Ahh thanks for that Branden - I was testing out a rollback so we'll need to do a manual restore.

Good to know. :)

Suggest an answer

Log in or Join to answer

Stay in touch

Be the first to know what's trending on Atlassian Community