Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Subtask disappear from the active sprint when I change state.

Hello

I have this behavior only in one project.

I try to investigate and after a disappearance of the subtask in the board 

(if I open the parent task, the subtask is clearly visible. All status are mapped in the board ) 

Screenshot 2020-12-01 at 23.28.34.pngScreenshot 2020-12-01 at 23.28.29.png

I do this 2 jql queries

Screenshot 2020-12-01 at 22.55.23.pngScreenshot 2020-12-01 at 22.55.03.png

If I filter with the current sprint, one subtask disappear of the result....
it seems that the displayed value is not the real value.

To fix this behaviour I should change the sprint of the parent task to another sprint  save and select the old value and save again.

Has anyone ever had this kind of problem before?

 

Thank you

 

 

 

1 answer

0 votes

This is because sub-tasks do not have an independent sprint field.

This is technically correct - a sub-task cannot be in a different sprint to the issue of which it is a part, so there's no need for the sprint field to be on it.

But it is annoying that it breaks reporting like this.

You can usually spot a Jira I've been an admin on, there will be a (scripted) field called something like "Sprint (inc sub task)", which is a copy of the sprint for all issue types.

Thanks for your answer but my problem is not the report. My problem is this:

https://youtu.be/6j7r0PF7SUo 

I do the report to understand what is happening

I don't understand what the video is trying to show us.  It has nothing to do with your question about the filters.

As you can see in the video one substask disappear "playrts-2157" when I change the state of this subtask on the board. How to to reproduce:

I change the status of a subtask by moving it around in the board it updates, I go back to the initial state. I make the same move as the first time a few seconds before and then it disappears.

When I try to investigate I do this the filter query to understand what happen. In the filter query result if you  check value of the result you see the current sprint. 

If you do another query using the value of the sprint as a filter, only 1 sub-task appear. It's explain why the second sub-task suddenly disappear when I move  it on the board. 

My question: What  can cause this behavior ?

>I change the status of a subtask by moving it around in the board it updates, I go back to the initial state.

If it disappears from the board, how are you doing this move back to the previous state with it?

I change the sprint parent issue with another sprint, save it, change to the current sprint and save it. The subtask appear again in the board.

Daniel Ebers Community Leader Dec 05, 2020

From the video the card behaves differently.
In the first move of PLAYRTS-2157 to the right column (maybe this is your "done" column...) it stays there.
But: and after moving it back to where to came from and AGAIN moving it from the middle (your second try) to the right it disappears?!

Could you please check in "All" tab of PLAYRTS-2157 what was different when doing the very same move of the card the second time? There should be something logged.

Also: is there some kind of Automation active?
If the outcome would every time the same I would have said there is some workflow action active but obviously the outcome is different when doing the same thing twice.

Hello

Yes it 's disappear (the column done is on the right you can see it on the first post of this thread. 

Fall all the test no filter were active, all project use the same workflow. Only this project seems broken when I move some subtask. Other user with this project have the same issue.

No automation

I check the project today and all seem normal again, subtask didnt disapear again when I move it.....

Thanks for your feedback, I will check "All" tab, if this happen again.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Jira Core

How to manage many similar workflows?

I have multiple projects that use variations of the same base workflow. The variations depend on the requirements of the project or issue type. The variations mostly come in the form of new statuses ...

4,547 views 12 8
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you