Scriptrunner workflow functions have stopped working

We are running ScriptRunner 3.1.4, and am aware an update is available - since it is a paid update the preferred route is that I contact support first.

I am supporting a workflow that has several scripted postfunctions which launch subtasks based on selected check boxes during a transition:

subtasks1.png

subtasks2.png

Each of these contains a conditional script identical to the others except for the name of the select box under the "Subtasks" field, an example:

'Write Unit Test' in cfValues['Subtasks']*.value

These scripts suddenly stopped working one day and have not functioned since. I have tried disabling and re-enabling the plugin, to no effect.

Thanks in advance for any suggestions!

2 answers

Try to find any error messages into atlassian-jira.log.

First, did you try the latest free update, 4.1.3.5? Second, which Jira version are you currently running? Third, did any other plugin or Jira itself get updated prior to your script failures?

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Bridget Sauer
Published Thursday in Marketplace Apps

Calling all developers––You're invited to Atlas Camp 2018

 Atlas Camp   is our developer event which will take place in Barcelona, Spain  from the 6th -7th of   September . This is a great opportunity to meet other developers and get n...

86 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you