Querying the Current JIRA Database

I am running the query quoted here:

Querying the Current JIRA Database

in Script Console, but I get: null

Scriptrunner version is 3.1.4

JIRA 6.4.9

Thanks in advance,

2 answers

1 accepted

Looks that the Script Console only show results if you use return in the code, so instead of:

log.debug sb.toString()

I use

return sb.toString()

to show the results of the query.

Personally I use the built in method to query JIRA's internal tables .  They replacing your connection declaration with this one.  I cant say for sure it will work as it as I use pure java implementation.

import com.atlassian.jira.ofbiz.DefaultOfBizConnectionFactory; 
Connection conn = new DefaultOfBizConnectionFactory().getConnection();

 

 

 

 

 

 

 

Thanks. Tried that but I still get null.

Suggest an answer

Log in or Join to answer
Community showcase
Emilee Spencer
Published yesterday in Marketplace Apps

Marketplace Spotlight: DeepAffects

Hello Atlassian Community! My name is Emilee, and I’m a Product Marketing Manager for the Marketplace team. Starting with this post, I'm kicking off a monthly series of Spotlights to highlight Ma...

38 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot