Mystic disconnection from the Confluence/JIRA servers running in a VMware machine

Hello Confluence / JIRA administrators out there!

I work as a university professor and I use Confluence / JIRA / Bitbucket / Bamboo for my courses that our students can learn about modern tools. I have worked in industries with Atlassian tools since 2006, so I am familiar with them. Now, I set up an environment and run into some (mystic .) trouble. Hope, that somebody can help.

The Configuration

I got two virtual machines from the university, running with modern computer hardware. The configuration:
VMware, 2 CPU, 8 GB RAM, Win Server 2012 R2. Both have open port 80 and 443.
Both are reachable over two URL, URL1 and URL2 resp. I set up SSL-connections with certificates from our university's CA. On machine 1, I run Confluence and on machine 2, JIRA and Bitbucket, and GIT, later I want to install Bamboo. Machine 2 also has an Apache 2.4 running to address JIRA with URL2/track and Bitbucket with URL2/scm. Both Atlassian's tomcat got 3 GB RAM. They run as windows services. All three applications are connected with application links. Databases: PostgreSQL 9.3. Everything runs fine.

The Problem

Every 3 to 10 days it happens that either the one or the other server is not reachable. It means in detail:

  • I cannot connect over the URL(s): timeout
  • I cannot - which is more serious -  connect the Windows server over RDP, which is the normal administration tool of the server.

I have to raise a ticket for the university's IT administration that they restart the VM machine. Then, it works again for a period of time.

I have not found any relation to an action preceding these problems. The load is not much, up to 5 users. I also got a CPU recording from the IT administration: no unusual CPU usage, 
Mystic: absolute nothing found in the logs and in the windows event records: no entries in the period in between my last usage in the time the machine is unreachable.

Done so fare

  • In the night, all servers stop planed with windows task scheduler, backup is done, and machines are restarted. XML backup is disabled.
  • Memory is increased, (see above), Tomcats got 3 GM, VM got 8 instead of 4 GB.

This is some very mystic to me, as I have done Java application development for 14 years, but one never stops learning .) 

Does anybody has some experiences with this? For the moment, I could suspect the plugins I use (about 15 on each machine), but - they belong somehow to the system - it should work.

Any help much welcome!

Cheers,
Mike 

 

1 answer

1 accepted

It's the network card, stupid!

Yes, indeed. A VMware Guest gets a virtual network card, in my case the Intel(R) PRO/1000 MT (E1000?). This causes the problem. It was fine to reach an apache http server with the default page "It works!". Enabling JIRA works fine for one or two days, but then network stops working. For some further days, it was still possible to reach the apache server, but this also stops after some time. 

VMware wrote about this recently here: https://kb.vmware.com/kb/2109922

The solution is to switch to a vmxnet3 Ethernet Adapter and using VMtools. 

This works fine for me, even a bit faster in my impression. Now, JIRA and Confluence are working stable even with plugins enabled on the two VMware Windows Server 2012 R2 systems.

Cheers,
Mike

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Fadoua M. Boualem
Published yesterday in Trello

Using Trello to manage events

As a Jira power user, I was at first doubtful that Trello could benefit my workflow. Jira already uses boards (ones you can customize!), so why would I even need to use Trello?! In this post you will...

446 views 6 7
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you