Jira Core Server 7.1 Trial

Hi,

I've installed the JIRA Core's one month trial version, but it's failing to load cause it says "Atlassian JIRA is starting up, Running system startup tasks ..." and it's the same message for 8 hrs now. 
Kindly note that i've uninstalled it and re-installed it again as a troubleshoot step, but still same results.

Your assistance is highly appreciated.

Thanks 

2 answers

This widget could not be displayed.

That one-off process can take a couple of minutes, even up to 20 on underpowered servers, but not 8 hours.  That means it's gone wrong.  What do the log files say?  (Catalina.out is worth a look, but the main one is atlassian-jira.log in jira-home/logs)

This is a copy of the first couple of line of atlassian-jira.log:

2016-06-22 15:41:37,748 JIRA-Bootstrap INFO [c.a.jira.startup.JiraStartupLogger]

****************
JIRA starting...
****************

2016-06-22 15:41:37,860 JIRA-Bootstrap INFO [c.a.jira.startup.JiraStartupLogger]

___ Environment _____________________________

JIRA Build : 7.1.7#71011-sha1:2526d7c13af2ab43673b0a163ceecff6fe735c9c
Build Date : Tue May 17 00:00:00 EET 2016
JIRA Installation Type : Standalone
Application Server : Apache Tomcat/8.0.32 - Servlet API 3.1
Java Version : 1.8.0_74 - Oracle Corporation
Current Working Directory : C:\Program Files\Atlassian\JIRA
Maximum Allowable Memory : 683MB
Total Memory : 377MB
Free Memory : 223MB
Used Memory : 154MB
Memory Pool: Code Cache : Code Cache: init = 2555904(2496K) used = 13521600(13204K) committed = 13565952(13248K) max = 251658240(245760K)
Memory Pool: Metaspace : Metaspace: init = 0(0K) used = 20682584(20197K) committed = 21233664(20736K) max = -1(-1K)
Memory Pool: Compressed Class Space : Compressed Class Space: init = 0(0K) used = 2428512(2371K) committed = 2621440(2560K) max = 1073741824(1048576K)
Memory Pool: PS Eden Space : PS Eden Space: init = 67108864(65536K) used = 92335544(90171K) committed = 205520896(200704K) max = 225968128(220672K)
Memory Pool: PS Survivor Space : PS Survivor Space: init = 11010048(10752K) used = 10998736(10740K) committed = 11010048(10752K) max = 11010048(10752K)
Memory Pool: PS Old Gen : PS Old Gen: init = 179306496(175104K) used = 59535480(58140K) committed = 179306496(175104K) max = 536870912(524288K)
JVM Input Arguments : -Djava.awt.headless=true -Datlassian.standalone=JIRA -Dorg.apache.jasper.runtime.BodyContentImpl.LIMIT_BUFFER=true -Dmail.mime.decodeparameters=true -Dorg.dom4j.factory=com.atlassian.core.xml.InterningDocumentFactory -Dcatalina.home=C:\Program Files\Atlassian\JIRA -Dcatalina.base=C:\Program Files\Atlassian\JIRA -Djava.endorsed.dirs=C:\Program Files\Atlassian\JIRA\endorsed -Djava.io.tmpdir=C:\Program Files\Atlassian\JIRA\temp -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Djava.util.logging.config.file=C:\Program Files\Atlassian\JIRA\conf\logging.properties exit -Xms256m -Xmx768m
Java Compatibility Information : JIRA version = 7.1.7, Java Version = 1.8.0_74

Um, that's the healthy bit.  Might be useful later, but what does the log say the problem is?  Where is it stopping?

Hi, sorry for the late reply, I had to wait cause i was out of points.

Below is a copy of the end of the atlassian-jira.log

 

2016-06-27 16:22:49,686 JIRA-Bootstrap INFO [c.a.jira.startup.JiraStartupLogger]

**********************************************************************************
JIRA 7.1.7 build: 71011 started. You can now access JIRA through your web browser.
**********************************************************************************

2016-06-27 16:22:49,699 JIRA-Bootstrap INFO [c.a.plugin.manager.DefaultPluginManager] Plugin system lateStartup begun
2016-06-27 16:22:49,702 JIRA-Bootstrap INFO [c.a.plugin.manager.DefaultPluginManager] Plugin system lateStartup ended
2016-06-27 16:22:49,703 JIRA-Bootstrap DEBUG [c.a.activeobjects.osgi.ActiveObjectsServiceFactory] getService bundle [com.atlassian.plugins.atlassian-whitelist-api-plugin]
2016-06-27 16:23:15,804 Modification Check:thread-1 INFO [c.a.jira.startup.JiraStartupLogger]

___ Modifications ___________________________

Modified Files : jira-application.properties
Removed Files : None

2016-06-27 16:24:43,496 hipchat-plugin-tasks-executor-0 DEBUG [c.a.activeobjects.osgi.ActiveObjectsServiceFactory] getService bundle [com.atlassian.plugins.base-hipchat-integration-plugin-api]

There should be more, that's implying it's stopped dead.  What does catalina.out say?  Is the CPU and memory being used by the process?

I've attached the catalina log.

That looks healthy too.  What is the CPU doing?

This widget could not be displayed.

I ran in that problem too. I have version 7.1.9 and have been used JIRA for several years now. I have an up to date license too.

I ended up stopping and restarting JIRA 3 or 4 times and it finally worked. Usually, it takes about 2 minutes to get started, with the CPUs pegged at 400% (even though our machine has only 2 CPUs). Once that process is over, I check to see whether it succeeded or not.

On my last try, I used the startup.sh directly, as the JIRA user, to see whether it would spit out some errors. I did not trust the systemd journal 100%... And that's when it started to work again.

sudo su - jira
cd /opt/atlassian/jira
bin/startup.sh

The normal output with no errors appeared and a couple of minutes later I could access the system, finally.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

178 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you