JQL Search for/order by custom field value wont work

Hi!

JIRA Core 7.1.9, Red Hat

I am having troubles with sorting/searching of custom fields.

I have a numeric custom field and when I use it within order by, the result is still unordered.

Also when I am searching for a specific value (which exists) I dont get any results.

There is no difference when using the custom field name or the cf[xxxxx] syntax. 

The field vallue is set by a custom plugin.

I dont know what is going on here and I would appreciate any hints on how to solve this!

Thanx in advance & Regards,

Hans

1 answer

1 votes

>The field vallue is set by a custom plugin.

Best guess is that the value, while being set by the plugin, is not being indexed correctly.  Try re-indexing and see if that improves the situation.

I had the same problem and it was solved when re-indexing.

Hi!

Thanx for the Replies!

Yes, reindexing did the trick and I managed to do an issue reindex after updating within my plugin.

Regards,

Hans

Suggest an answer

Log in or Join to answer
Community showcase
Teodora [Botron]
Published Thursday in Marketplace Apps

Jira Inferno: The Nine Circles of Jira Administration Hell

If you spend enough time as a Jira admin - whether you are managing a single, mid-sized instance, a large enterprise one or juggling multiple instances at once - you will eventually find yourself in ...

319 views 0 12
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot