JIRA unable to start due to disabled plugins

I have a sandbox that I upgraded from 7.0.11 to 7.3.8 and I can't get it to startup due to some plugins being disabled. Before I upgrade my instance I had put the add-ons onto safe mode. After I started JIRA I came across the following error. 

jira-startup.png

I've tried to following the solution on this page with enabling the plugins through mySQL https://confluence.atlassian.com/jirakb/troubleshooting-jira-startup-failed-error-394464512.html#TroubleshootingJIRAStartupFailedError-Time and I don't think this is a time out issue or any of the other issues listed. Also when I look for all the plugins available I can't seem to find the new plugins in the database. I'm wondering I'm missing these plugins from the get go (ie I somehow managed to skip installing them during the upgrade process) or if this is a configuration or some other issue due to me putting the add-ons in safe mode before I upgraded my instance.

1 answer

1 accepted

Try extending the plugin timeout and try again: https://confluence.atlassian.com/jirakb/jira-applications-system-plugin-timeout-while-waiting-for-add-ons-to-enable-212173447.html

Also, make sure all SYSTEM ADD-ONs and modules are enabled before upgrading JIRA. This shouldn't be a problem for you if you used Safe Mode; however some admins disable things like HipChat module. Make sure all system add-ons are enabled.

I tried extending the timeout to 300 secs and then again to 1200 secs when it didn't work. My JIRA instance starts up just fine now, thank you!

No problem. There's probably a plugin problem here, 300 seconds is a very long time, so 1200 seconds is kinda rediculous. My unlimited user Confluence with tons of plugins finishes loading plugins in something like 60 seconds. My 10000 user JIRA with tons of plugins and custom plugins takes about 90 seconds to start.

There could be bad data, a bad plugin, old plugins, something.

I've been looking to clean up the plugins to see what I can get rid of before upgrading the production server, so I'll look into it. Thank you for the suggestion. I suspect it might be an issue with some of the custom plugins we've created for our company, but I'll have to check. The plugins took less than 1200 secs to load, but I wanted it to be a lot bigger to just check that it was a timeout issue. I think around 500-600 secs might be alright for the load time.

Gotcha. I didn't run into this same problem but I had similar issues when upgrading to 7.2.x.

My issue was that old system plugins had been disabled and weren't being upgraded. This includes things like Hipchat Plugin, Service Desk Modules, etc. Then JIRA would try to load the old system plugin and the new system plugin and fail.

Good luck! :)

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted yesterday in Jira Service Desk

Looking for anyone who has switched from Zendesk to Jira Service Desk

Hi Community! The Jira Service Desk marketing team is looking for customers who have successfully switched from Zendesk to Jira Service Desk!   We’d love to hear your thoughts on the pros and ...

23 views 0 1
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you