I'm getting an "unsupported field encountered: binary" error when trying to restore my JIRA backup?

(SOLVED BELOW.   I just wanted the community to be aware as it took me a full day in support to find out).

In JIRA, I was trying to Restore one of my Backups and I was getting the error:

java.lang.IllegalArgumentException: Unsupported field encountered: binary

None of my backups from the past 2 weeks were able to be imported with Restore Backups as I kept seeing this error. 

2 answers

After talking to Atlassian Support for a full day to try to get them to find out what values in my backup XMLs are causing problems, they found this XPORTER-681 issue where the add-on was setting a column value as Binary which JIRA does not support. 

I tried to replace binary with string but that failed, so eventually I just removed all of my Xporter table configurations from the activeobjects.XML backup file, re-zipped it up, and the restore worked fine. 

However, note that Xporter will not work immediately after this as I had to remove all of those table values, so I'm just reinstalling it.

Allegedly, from that bug report it looks like it was fixed in 4.0.4 but I was still using 4.0.4, so maybe I'm reading it wrong and it's fixed in the more current release.

Hi Geoff,

Is it fixed now?

Thanks.

Rui.

Big thanks for your investigation. Today I lost half-day for this problem. 

I have Xporter 4.1.1, upgrade not fixed this bug, problematic field was not removed.After remove Xporter tables from backup JIRA restored fine. 

I was try install Xporter back, config it, add templates and create a few exports. After that, none "binary" exists in Xporter tables in new backup of Jira.

Hi,

I get something similar. I want to import project from JIRA cloud backup to JIRA server but i get a non explicit error like this:

 

There was a problem with the SAX parsing of the file 'my_jira_backup_file.zip' when performing a project import.
org.xml.sax.SAXException: Unrecognised AO Data Type
        at com.atlassian.jira.imports.project.ao.handler.ChainedAoSaxHandler.endNestedElement(ChainedAoSaxHandler.java:231)
        at com.atlassian.jira.imports.project.ao.handler.ChainedAoSaxHandler.endElement(ChainedAoSaxHandler.java:195)
        at com.atlassian.jira.imports.project.ao.handler.ChainedAoSaxHandler.endElement(ChainedAoSaxHandler.java:148)
etc...

So i dedide to install a fresh test JIRA server instance to last version (7.2.4) to try restoring my cloud backup. Then i got the same message as you describe.

I just removed the line with <binary>binary information</binary> located at the end of the activeobjects.xml file in the JIRA cloud backup.

It works and i can import a project from the JIRA cloud backup to my runing JIRA server instance!

Hope it help...

Suggest an answer

Log in or Join to answer
Community showcase
Emilee Spencer
Published yesterday in Marketplace Apps

Marketplace Spotlight: DeepAffects

Hello Atlassian Community! My name is Emilee, and I’m a Product Marketing Manager for the Marketplace team. Starting with this post, I'm kicking off a monthly series of Spotlights to highlight Ma...

44 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot