How to connect to Pervasive DB

Hi,

I'm trying to connect Pervasive to create KCF Pro Single Auto complete drop down and not able to proceed ..

I copied jar files to lib folder and prepared below template based on this data  https://confluence.kepler-rominfo.com/display/DBCF/Data+Source+Configuration 

<Resource name="easyDB"

          auth="Container" type="javax.sql.DataSource"

          username=“usernmae"

          password=“password"

          driverClassName="com.pervasive.jdbc.v2.Driver"

          url="jdbc:pervasive://IP Address:1583/DB Name?transport=tcp"

 />


But I'm always getting error message " com.pervasive.jdbc.v2.Connection.isValid(I)Z" with return code 500

2 answers

1 vote

Hello, 

 

It's a generic error message, given when an unexpected condition was encountered and no more specific message is suitable. With JDBC, that error usually occurs because your JDBC driver implements an older version of the JDBC API than the one included in your JRE or that is incompatible with your JRE/JDK version. 

However, keep in mind pervasive DB isn't supported as you can check on this documentation: https://confluence.atlassian.com/jira/supported-platforms-207488170.html

Even if you are able to setup this connection, you can face other issues due this configuration. 

 

Cheers, 

Renato Rudnicki

Hi Renato, Thanks for reply. I'm not trying to connect pervasive DB for whole JIRA application, i'm trying to connect to Pervasive DB only for one KCF pro custom field. 1. Copied pervasive JDBC driver .jar files under JARA/lib folder 2. Added this entry for context.xml under JARA/Conf folder <Resource name="easyDB" auth="Container" type="javax.sql.DataSource" username=“usernmae" password=“password" driverClassName="com.pervasive.jdbc.v2.Driver" url="jdbc:pervasive://IP Address:1583/DB name" /> by referring this example https://confluence.kepler-rominfo.com/display/DBCF/Data+Source+Configuration 3. Created Sql data source with simple autocomplete script " select job_name from job where job_name like {query} || '%';" It seems to be KCF pro doesn't support Pervasive DB.

After seeing the stacktrace, we discovered that the jdbc driver does not implement the method isValid, added in jre6.

So, it is not an problem with KCF Pro plugin but with the jdbc, which was, most probably, developed under java 5 and  didn't get updated accordingly to newer versions of java..
Our suggestion is to ask for support the Pervasive team. Maybe they have another jdbc driver available (we have already taken a look at v11 SP3 and it does not fit) or if/when they plan to add one with support for higher versions of java. 

 

Alexandra

Suggest an answer

Log in or Sign up to answer
Community showcase
Published yesterday in Jira Ops

Jira Ops Early Access Program Update #2: Let’s talk severity levels

Welcome to your weekly Jira Ops Early access program update, where we’re sharing news and updates on Jira Ops' progress as we work toward our 1.0 release. If you ever want to drop us feedback or idea...

41 views 0 0
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you