Custom Field Search Not Returning Results

As of 2 days ago I am getting misleading results in doing custom field search.  My team has a Salesforce ID field where we cross reference CRM cases and we have always been able to search through the field using global search or writing an advanced query with the ~ operator.  It doesn't seem to quite work now.  I have two JIRA cases with the same Salesforce ID, and it is only returning the first (numerically and chronologically) and not all of them.  The text box is configured with the free text search template.

I have also re-indexed the instance as well.

 

2 answers

This widget could not be displayed.

I believe it depends on the kind of search you're executing, there are some validators like WAS and CHANGED which doesn't work for custom fields:

 

https://jira.atlassian.com/browse/JRA-27641

 

Cheers,

Rodrigo Silva

This widget could not be displayed.
Steven Behnke Community Champion Nov 25, 2015

Please let us know how you have integrated Sales Force with your JIRA. If are using the Cloud Mappings add-on supported by Service Rocket for instance, that'd be information we need to know.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

220 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you