Certain fields not shown in custom fields list

Hi Team,

Certain custom fields have been vanished from the custom fields list. Those fields are visible in the issue create screen and field configuration area. It is only vanished from custom fields section. Please help in resolving this issue.

 

Regards,

Pavithra D

1 answer

0 votes

By custom fields section, I assume you mean in the issue view?  I'd guess the fields are empty, as JIRA hides them on view.

Hi Nic,

Thanks for your quick response.

Nope. I am not mentioning the issue view. The fields are not visible from the 'custom fields' section where we will create and configure them.

Custom fields are sorted in alphabetical order in which the fields starts with i,j,k,l are vanished.

Regards,

Pavithra D

 

Yes, "custom fields section" is wonderfully unclear on what you are looking at (there's at least six that spring to my mind)

I now assume you mean in the administration functionality.  Disappearing fields in there are down to either invalid field names, or, more often, people botching javascript into field descriptions (never do that, it's always the wrong thing to do)

Have you got any javascript or dodgy field names?

Hi Nic,

yeah. I am talking about the custom fields administration page.

image2017-3-14 17:3:29.png

 

And as you mentioned, I have added a java script to a field description.

Regards,

Pavithra D

Hi Nic,

I Have removed the java script which i have added, re-indexed and restarted, but still the issue persists. How can i resolve this issue? Please share the workaround for the same.

 

Thanks and Regards,

Pavithra D

Did you remove all the scripts from all field descriptions?

when i removed the script from one field all the other fields below them got disappeared sad now only the fields from A to I is visible.

Regards,

Pavithra D

Ok, do one or more of of the broken fields have javascript too?

Could you view the raw html of the filed list in the admin screen and see if the fields are in there?

Hi Nic,

Thanks for your support.

The issue has been resolved by deleting the script from the tables 'CUSTOMFIELD' and 'FIELDLAYOUTITEM'.

Regards,

Pavithra D

Suggest an answer

Log in or Join to answer
Community showcase
Teodora [Botron]
Published Thursday in Marketplace Apps

Jira Inferno: The Nine Circles of Jira Administration Hell

If you spend enough time as a Jira admin - whether you are managing a single, mid-sized instance, a large enterprise one or juggling multiple instances at once - you will eventually find yourself in ...

922 views 5 18
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot