Aggregate value doesnt use decimals from custom fields

I have custom fields that have numerical data as values (also values that include decimals - 1.5 or 10.1 etc)

When doing an aggregation, the sum leaves out the decimal part:

1.5 + 10.9 = 11

 

It does work correctly on standard fields, though ...

 

Any ideas on what should i check or change?

Thanks

3 answers

What do you mean b\y the aggregation? How do you do it? Some JavaScript or addon or in excel?

0 vote
Tarun Sapra Community Champion Jan 26, 2017

If you are using script runner for, make sure you use "Double" type 

How exactly do I control that?

When I create a new custom field, I just have the option to choose "Number Field" ...

Tarun Sapra Community Champion Jan 27, 2017

Put the (Double) type casting where the aggregation is taking place. which plugin are you using for this functionality?

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Bridget Sauer
Published Thursday in Marketplace Apps

Calling all developers––You're invited to Atlas Camp 2018

 Atlas Camp   is our developer event which will take place in Barcelona, Spain  from the 6th -7th of   September . This is a great opportunity to meet other developers and get n...

78 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you